Exposure of Private Personal Information to an Unauthorized Actor in alextselegidis/easyappointmentsGHSA-r6cm-wg48-rh2r
CRITICALFix: alextselegidis/easyappointments@44af526GHSA-r6cm-wg48-rh2r is a critical-severity (CVSS 9.1) CWE-359 vulnerability in alextselegidis/easyappointments. 5 public exploit or proof-of-concept references are indexed, so weaponization risk is real. A fix is available for alextselegidis/easyappointments — see the affected versions and patch details below.
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
How urgent is this, really
Where this sits among everything scored
Real-World Exposure
alextselegidis/easyappointmentsReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects Packagist packages — download data is not available via public APIs for these ecosystems.
Description
The software is a booking management system that has a public form to place bookings, and a private area for the calendar and management of services, users, settings, etc. There is a backend API that allows data manipulation, including listing the appointments for a specific time range. This happens on this endpoint: /index.php/backend_api/ajax_get_calendar_events Unfortunately, there is no authentication / permissions-check on that endpoint, the only required parameters in a POST request are "startDate", "endDate" and "csrfToken". Because the csrfToken can be obtained by any unauthenticated user just visiting the public form (and is valid for the backend as well), any attacker can query the backend API and obtain all sorts of private information about the appointment, in JSON format.
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| 🐘Packagist | alextselegidis/easyappointments | all versions | 1.4.3composer require alextselegidis/easyappointments:^1.4.3 |
Affected Products
easyappointmentseasyappointmentsResearch use only. For defensive security, authorized penetration testing, and academic research only. Never execute exploit code against systems without explicit written authorization.
Easy Appointments 1.4.2 - Information Disclosure
by Alexandre ZANNI · Apr 19, 2022
Detection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for alextselegidis/easyappointments, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update alextselegidis/easyappointments to 1.4.3 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms GHSA-r6cm-wg48-rh2r is resolved across your whole dependency graph.
Workarounds
Put an independent control in front of the weakness: restrict the affected endpoint or interface to trusted networks, require an additional authentication factor or proxy-level check, and invalidate existing sessions and credentials in case the flaw has already been used.
How to detect GHSA-r6cm-wg48-rh2r
A community-maintained Nuclei template exists for this CVE. You can scan for it directly:
nuclei -id ghsa-r6cm-wg48-rh2r -u https://target- Template
- Easy!Appointments <1.4.3 - Broken Access Control
- Severity
- critical
- Impact
- An attacker can exploit this vulnerability to gain unauthorized access to sensitive data or perform unauthorized actions.
- Remediation
- Upgrade Easy!Appointments to version 1.4.4 or above to fix the Broken Access Control vulnerability.
Template by ProjectDiscovery nuclei-templates (francescocarlucci, opencirt), MIT licensed. View the full template. Scan only systems you are authorised to test.
Frequently Asked Questions
Is GHSA-r6cm-wg48-rh2r in your dependencies?
Find it across Packagist, including transitive dependencies.