node-fetch forwards secure headers to untrusted sitesGHSA-r683-j2x4-v87g
HIGHFix: node-fetch/node-fetch#1449GHSA-r683-j2x4-v87g is a high-severity (CVSS 8.8) Information Exposure vulnerability in node-fetch. 1 public exploit or proof-of-concept reference is indexed, so weaponization risk is real. A fix is available for node-fetch — see the affected versions and patch details below.
Exploitation Status
No confirmed exploitation observed yet
- CISA’s own triage has not observed active exploitation or public proof-of-concept code for this CVE as of its last assessment.
Exploitation and automatability from CISA’s SSVC triage for GHSA-r683-j2x4-v87g.
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
How urgent is this, really
Where this sits among everything scored
Real-World Exposure
How broadly this vulnerability is actually deployed: weekly install volume shows current usage, and reverse-dependency count shows how many other packages break if it stays unpatched.
node-fetchnpmDescription
node-fetch forwards secure headers such as authorization, www-authenticate, cookie, & cookie2 when redirecting to a untrusted site.
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| 📦npm | node-fetch | ≥ 3.0.0&&< 3.1.1 | 3.1.1npm install node-fetch@3.1.1 |
| 📦npm | node-fetch | all versions | 2.6.7npm install node-fetch@2.6.7 |
Affected Products
debian linuxdebiannode-fetchnode-fetch_projectsinec inssiemensResearch use only. For defensive security, authorized penetration testing, and academic research only. Never execute exploit code against systems without explicit written authorization.
Detection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for node-fetch, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update node-fetch to 3.1.1 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms GHSA-r683-j2x4-v87g is resolved across your whole dependency graph.
Workarounds
Stop reflecting attacker-controlled destinations: resolve every redirect target against an allowlist of paths or hosts you own, prefer a server-side key over a full URL in the request, and reject absolute URLs entirely where the flow only ever needs a relative one.
Fixing This On Your OS
If you run this on a Linux distribution, patch through your package manager against the distro's own security advisory below — it tracks the exact backported fix for your release, which can ship on a different timeline (and sometimes a different severity) than the upstream project.
This flaw is out of support scope for dotnet-5.0. For more information about Dotnet product support scope, please see https://access.redhat.com/support/policy/updates/net-core
| Product | Fixed in | Advisory |
|---|---|---|
| OpenShift Service Mesh 2.1 | openshift-service-mesh/kiali-rhel8:1.36.9-1 | RHSA-2022:1739 |
| Red Hat Data Grid 8.4.0 | node-fetch | RHSA-2022:8524 |
| Red Hat Enterprise Linux 8 | nodejs:14-8070020221212161539.bd1311ed | RHSA-2023:0050 |
| Red Hat Enterprise Linux 8.6 Extended Update Support | nodejs:14-8060020230306170237.ad008a3a | RHSA-2023:1742 |
| Red Hat Migration Toolkit for Containers 1.7 | rhmtc/openshift-migration-ui-rhel8:v1.7.2-9 | RHSA-2022:5483 |
| Red Hat OpenShift Container Platform 4.11 | openshift4/ose-thanos-rhel8:v4.11.0-202208020235.p0.gf08da2d.assembly.stream | RHSA-2022:5069 |
| Red Hat OpenShift Data Foundation 4.11 on RHEL8 | odf4/mcg-core-rhel8:v4.11.0-30 | RHSA-2022:6156 |
| Red Hat Software Collections for Red Hat Enterprise Linux 7 | rh-nodejs14-nodejs-0:14.21.1-3.el7 | RHSA-2023:0612 |
Frequently Asked Questions
Is GHSA-r683-j2x4-v87g in your dependencies?
Find it across npm, including transitive dependencies.