cert-manager ha a potential slowdown / DoS when parsing specially crafted PEM inputsGHSA-r4pg-vg54-wxx4
Fix: cert-manager/cert-manager#7400GHSA-r4pg-vg54-wxx4 is a Improper Input Validation vulnerability in github.com/cert-manager/cert-manager. A fix is available for github.com/cert-manager/cert-manager — see the affected versions and patch details below.
Exploitation Status
No confirmed exploitation observed yet
- CISA’s own triage has not observed active exploitation or public proof-of-concept code for this CVE as of its last assessment.
Exploitation and automatability from CISA’s SSVC triage for GHSA-r4pg-vg54-wxx4.
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
Real-World Exposure
github.com/cert-manager/cert-manager🐹github.com/cert-manager/cert-manager🐹github.com/cert-manager/cert-managerReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects Go packages — download data is not available via public APIs for these ecosystems.
Description
Impact
cert-manager packages which call the standard library pem.Decode() function can take a long time to process specially crafted invalid PEM data.
If an attacker is able to modify PEM data which cert-manager reads (e.g. in a Secret resource), they may be able to use large amounts of CPU in the cert-manager controller pod to effectively create a denial-of-service (DoS) vector for cert-manager in the cluster.
Secrets are limited in size to 1MiB, which reduces the impact of this issue; it was discovered through an ~856kB fuzz test input which causes pem.Decode to take roughly 750ms to reject the input on an M2 Max Macbook Pro. By way of comparison, a valid PEM-encoded 4096-bit RSA key takes roughly 70µs to parse on the same machine.
Given the required size of PEM data needed to present a realistic DoS vector, an attacker would need to create or insert many different large sized resources in the cluster, and so the best secondary defense is to ensure that sensible limits are placed via RBAC.
This issue affects all versions of cert-manager to have been released since at least v0.1.0 (since pem.Decode is core functionality for cert-manager). All supported releases are patched.
Patches
The fixed versions are v1.16.2, v1.15.4 and v1.12.14.
- master branch: https://github.com/cert-manager/cert-manager/pull/7400
- release-1.16 branch: https://github.com/cert-manager/cert-manager/pull/7401
- release-1.15 branch: https://github.com/cert-manager/cert-manager/pull/7402
- release-1.12 branch: https://github.com/cert-manager/cert-manager/pull/7403
Workarounds
Ensure that RBAC is scoped correctly in your cluster. If a user is able to modify resources containing PEM data to be able to exploit this, it's like that those permissions are a bigger security threat than this issue - especially for Secret resources.
References
- Upstream issue: https://github.com/golang/go/issues/50116
- Similar issue: https://github.com/sigstore/sigstore/issues/198
- Google OSSFuzz: https://issues.oss-fuzz.com/issues/376728466
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| 🐹Go | github.com/cert-manager/cert-manager | all versions | 1.12.14go get github.com/cert-manager/cert-manager@v1.12.14 |
| 🐹Go | github.com/cert-manager/cert-manager | ≥ 1.13.0-alpha.0&&< 1.15.4 | 1.15.4go get github.com/cert-manager/cert-manager@v1.15.4 |
| 🐹Go | github.com/cert-manager/cert-manager | ≥ 1.16.0-alpha.0&&< 1.16.2 | 1.16.2go get github.com/cert-manager/cert-manager@v1.16.2 |
Detection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for github.com/cert-manager/cert-manager, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update github.com/cert-manager/cert-manager to 1.12.14 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms GHSA-r4pg-vg54-wxx4 is resolved across your whole dependency graph.
Workarounds
Cap what an attacker can consume: apply request size, rate and timeout limits in front of the affected component, and run it with memory and CPU limits so exhaustion degrades one worker rather than the whole service.
Frequently Asked Questions
Is GHSA-r4pg-vg54-wxx4 in your dependencies?
Find it across Go, including transitive dependencies.