NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
📦 npm
Not in CISA KEV

Angular critical CSS inlining Cross-site Scripting Vulnerability AdvisoryGHSA-r3hf-q8q7-fv2p

GHSA-r3hf-q8q7-fv2p is a security vulnerability in @nguniversal/common. A fix is available for @nguniversal/common — see the affected versions and patch details below.

Published
Updated
Affected
1 pkg
Patched
1 / 1
Exploits
None indexed
Exploitation data as of Aug 9, 2023 · OSV.dev, FIRST.org (EPSS)

Real-World Exposure

1 pkg affected

How broadly this vulnerability is actually deployed: weekly install volume shows current usage, and reverse-dependency count shows how many other packages break if it stays unpatched.

37other npm packages depend on this — each one inherits the vulnerability until it's patched upstream
@nguniversal/commonnpm
38Kdownloads / week

Description

Impact

Angular Universal applications on 16.1.0 and 16.1.1 using critical CSS inlining are vulnerable to a cross-site scripting (XSS) attack where an attacker can trick another user into visiting a page which injects malicious JavaScript.

Angular CLI applications without Universal do perform critical CSS inlining as well, however exploiting this requires a malicious actor to already have access to modify source code directly.

Patches

@nguniversal/common should be upgraded to 16.1.2 or higher. 16.2.0-rc.0 is safe.

Workarounds

The easiest solution is likely to upgrade Universal to 16.1.2 or downgrade to 16.0.x or lower. Alternatively you can override specifically the critters dependency with version 0.0.20 in your package.json.

{
  "overrides": {
    "critters": "0.0.20"
  }
}

References

Affected Packages

1 total 1 fixed
EcosystemPackageVulnerable rangeFix
📦npm@nguniversal/common≥ 16.1.0&&< 16.1.216.1.2npm install @nguniversal/common@16.1.2

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for @nguniversal/common, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update @nguniversal/common to 16.1.2 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms GHSA-r3hf-q8q7-fv2p is resolved across your whole dependency graph.

  3. Workarounds

    Escape or sanitise the affected output on the server side rather than relying on client-side filtering, and add a Content-Security-Policy that blocks inline script execution so injected markup cannot run even if it reaches the page.

Frequently Asked Questions

### Impact Angular Universal applications on 16.1.0 and 16.1.1 using critical CSS inlining are vulnerable to a [cross-site scripting (XSS)](https://owasp.org/www-community/attacks/xss/) attack where an attacker can trick another user into visiting a page which injects malicious JavaScript. Angular CLI applications without Universal do perform critical CSS inlining as well, however exploiting this requires a malicious actor to already have access to modify source code directly. ### Patches `@nguniversal/common` should be upgraded to 16.1.2 or higher. 16.2.0-rc.0 is safe. ### Workarounds The
O3 Security · Impact-Aware SCA

Is GHSA-r3hf-q8q7-fv2p in your dependencies?

Find it across npm, including transitive dependencies.

Angular critical CSS inlining Cross-site Scripting…