Shopware Customer Orders can be canceled, even if refunds are disabledGHSA-r2vg-hvjm-fg38
MEDIUMFix: shopware/shopware@b157508GHSA-r2vg-hvjm-fg38 is a medium-severity (CVSS 4.3) vulnerability in shopware/platform. A fix is available for shopware/platform — see the affected versions and patch details below.
Real-World Exposure
shopware/platform🐘shopware/platform🐘shopware/core🐘shopware/coreReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects Packagist packages — download data is not available via public APIs for these ecosystems.
Description
Refunds in general can be enabled through the administration setting core.cart.enableOrderRefunds (in the cart panel).Which visually shows and hides the button. However, using a custom crafted request, a customer can still cancel his own orders.As this is not checked inside the route (and also not in the controller):
https://github.com/shopware/shopware/blob/trunk/src/Storefront/Controller/AccountOrderController.php#L98
https://github.com/shopware/shopware/blob/trunk/src/Core/Checkout/Order/SalesChannel/CancelOrderRoute.php
To mitigate this, a check should be added to the CancelOrderRoute which verifies that the feature is enabled.
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| 🐘Packagist | shopware/platform | ≥ 6.7.0.0&&< 6.7.3.1 | 6.7.3.1composer require shopware/platform:^6.7.3.1 |
| 🐘Packagist | shopware/platform | all versions | 6.6.10.7composer require shopware/platform:^6.6.10.7 |
| 🐘Packagist | shopware/core | ≥ 6.7.0.0&&< 6.7.3.1 | 6.7.3.1composer require shopware/core:^6.7.3.1 |
| 🐘Packagist | shopware/core | all versions | 6.6.10.7composer require shopware/core:^6.6.10.7 |
Detection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for shopware/platform, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update shopware/platform to 6.7.3.1 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms GHSA-r2vg-hvjm-fg38 is resolved across your whole dependency graph.
Workarounds
If you can't upgrade right away: gate or disable the affected feature, validate untrusted input at the boundary, and avoid passing attacker-controlled data into the vulnerable path. O3's runtime protection blocks exploitation in production as an interim safeguard until the upgrade lands.
Frequently Asked Questions
Is GHSA-r2vg-hvjm-fg38 in your dependencies?
Find it across Packagist, including transitive dependencies.