NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
🐘
🐘 Packagist
Not in CISA KEV
MEDIUM severity

Connect-CMS Privilege Escalation VulnerabilityGHSA-qxh3-jgvh-x55j

MEDIUM

GHSA-qxh3-jgvh-x55j is a medium-severity (CVSS 4.3) vulnerability in opensource-workshop/connect-cms. A fix is available for opensource-workshop/connect-cms — see the affected versions and patch details below.

Published
Updated
Affected
2 pkgs
Patched
2 / 2
Exploits
None indexed
Exploitation data as of Feb 7, 2025 · OSV.dev, FIRST.org (EPSS)

Real-World Exposure

2 pkgs affected
🐘opensource-workshop/connect-cms🐘opensource-workshop/connect-cms

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects Packagist packages — download data is not available via public APIs for these ecosystems.

Description

Impact(影響)

There is a Privilege Escalation Vulnerability on the management system of Connect-CMS. Affercted Version : Connect-CMS 1.7.1, 2.3.1 and earlier

Patches(修正バージョン)

version 1.7.2, 2.3.1

Workarounds(運用回避手段)

Upgrade Connect-CMS to latest version

Affected Packages

2 total 2 fixed
EcosystemPackageVulnerable rangeFix
🐘Packagistopensource-workshop/connect-cmsall versions1.7.2composer require opensource-workshop/connect-cms:^1.7.2
🐘Packagistopensource-workshop/connect-cms≥ 2.0.0&&< 2.3.22.3.2composer require opensource-workshop/connect-cms:^2.3.2

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for opensource-workshop/connect-cms, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update opensource-workshop/connect-cms to 1.7.2 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms GHSA-qxh3-jgvh-x55j is resolved across your whole dependency graph.

  3. Workarounds

    Close the privilege gap rather than the entry point: audit which accounts, roles and service identities can reach the affected operation, drop the component to the least privilege it actually needs, and review file and directory permissions created by earlier installs — a default left in place is what makes this reachable.

Frequently Asked Questions

### Impact(影響) There is a Privilege Escalation Vulnerability on the management system of Connect-CMS. Affercted Version : Connect-CMS 1.7.1, 2.3.1 and earlier ### Patches(修正バージョン) version 1.7.2, 2.3.1 ### Workarounds(運用回避手段) Upgrade Connect-CMS to latest version
O3 Security · Impact-Aware SCA

Is GHSA-qxh3-jgvh-x55j in your dependencies?

Find it across Packagist, including transitive dependencies.

Connect-CMS Privilege Escalation Vulnerability