PHP League CommonMark vulnerable to Cross-Site Scripting (XSS)GHSA-qx76-c53f-5c7q
MEDIUMGHSA-qx76-c53f-5c7q is a medium-severity (CVSS 6.1) Cross-site Scripting (XSS) vulnerability in league/commonmark. 1 public exploit or proof-of-concept reference is indexed, so weaponization risk is real. A fix is available for league/commonmark — see the affected versions and patch details below.
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
How urgent is this, really
Where this sits among everything scored
Real-World Exposure
league/commonmarkReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects Packagist packages — download data is not available via public APIs for these ecosystems.
Description
Cross-site scripting (XSS) vulnerability in the PHP League CommonMark library versions 0.15.6 through 0.18.x before 0.18.1 allows remote attackers to insert unsafe URLs into HTML (even if allow_unsafe_links is false) via a newline character (e.g., writing javascript as javascri%0apt).
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| 🐘Packagist | league/commonmark | ≥ 0.15.6&&< 0.18.1 | 0.18.1composer require league/commonmark:^0.18.1 |
Affected Products
commonmarkthephpleagueResearch use only. For defensive security, authorized penetration testing, and academic research only. Never execute exploit code against systems without explicit written authorization.
Detection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for league/commonmark, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update league/commonmark to 0.18.1 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms GHSA-qx76-c53f-5c7q is resolved across your whole dependency graph.
Workarounds
Escape or sanitise the affected output on the server side rather than relying on client-side filtering, and add a Content-Security-Policy that blocks inline script execution so injected markup cannot run even if it reaches the page.
Frequently Asked Questions
Is GHSA-qx76-c53f-5c7q in your dependencies?
Find it across Packagist, including transitive dependencies.