Data Leakage Vulnerability in livewire/livewireGHSA-qwvp-268g-jjm8
Fix: livewire/livewire@6929f58GHSA-qwvp-268g-jjm8 is a security vulnerability in livewire/livewire. A fix is available for livewire/livewire — see the affected versions and patch details below.
Real-World Exposure
livewire/livewireReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects Packagist packages — download data is not available via public APIs for these ecosystems.
Description
livewire/livewire versions greater than 2.2.4 and less than 2.2.6 are affected by a data leakage vulnerability. The $this->validate() method, which is expected to return only the validated dataset, was returning all properties of the Livewire component. This regression introduced a security risk, allowing unvalidated data to be exposed, which could lead to unexpected behavior and potential security issues.
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| 🐘Packagist | livewire/livewire | ≥ 2.2.5&&< 2.2.6 | 2.2.6composer require livewire/livewire:^2.2.6 |
Detection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for livewire/livewire, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update livewire/livewire to 2.2.6 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms GHSA-qwvp-268g-jjm8 is resolved across your whole dependency graph.
Workarounds
If you can't upgrade right away: gate or disable the affected feature, validate untrusted input at the boundary, and avoid passing attacker-controlled data into the vulnerable path. O3's runtime protection blocks exploitation in production as an interim safeguard until the upgrade lands.
Frequently Asked Questions
Is GHSA-qwvp-268g-jjm8 in your dependencies?
Find it across Packagist, including transitive dependencies.