Leantime has HTML injection through firstname and lastname fieldsGHSA-qrfh-cc86-vc8c
MEDIUMFix: Leantime/leantime@3f8b2c6GHSA-qrfh-cc86-vc8c is a medium-severity (CVSS 5.4) vulnerability in leantime/leantime. A fix is available for leantime/leantime — see the affected versions and patch details below.
Real-World Exposure
leantime/leantimeReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects Packagist packages — download data is not available via public APIs for these ecosystems.
Description
Summary
Leantime v2.3.27 is vulnerable to Stored HTML Injection. The firstname and lastname fields in the admin user edit page are rendered without HTML escaping, allowing an authenticated user to inject arbitrary HTML that executes when the profile is viewed.
Vulnerable File
app/Domain/Users/Templates/editUser.tpl.php
Vulnerable Code (Lines ~14-17)
value="<?php echo $values['firstname'] ?>"
value="<?php echo $values['lastname'] ?>"
These fields output raw user input without sanitization.
Steps to Reproduce
- Login as admin > Go to Settings > Users > Edit any user
- Enter HTML payload in First Name or Last Name field:
<h1>INJECTED</h1> - Save the user profile
- Create or view an article — the injected HTML renders in the author name
Fix
Replace unescaped echo with htmlspecialchars():
value="<?php echo htmlspecialchars($values['firstname'], ENT_QUOTES, 'UTF-8') ?>"
value="<?php echo htmlspecialchars($values['lastname'], ENT_QUOTES, 'UTF-8') ?>"
Or use the existing $this->e() helper already used in editOwn.tpl.php.
Impact
- Stored HTML injection visible to all users viewing affected content
- Can be used for phishing, fake login forms, and UI defacement
- Affects all versions before 3.3.0
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| 🐘Packagist | leantime/leantime | all versions | 3.3.0composer require leantime/leantime:^3.3.0 |
Detection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for leantime/leantime, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update leantime/leantime to 3.3.0 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms GHSA-qrfh-cc86-vc8c is resolved across your whole dependency graph.
Workarounds
If you can't upgrade right away: gate or disable the affected feature, validate untrusted input at the boundary, and avoid passing attacker-controlled data into the vulnerable path. O3's runtime protection blocks exploitation in production as an interim safeguard until the upgrade lands.
Frequently Asked Questions
Is GHSA-qrfh-cc86-vc8c in your dependencies?
Find it across Packagist, including transitive dependencies.