OpenClaw's Telegram message_reaction authorization bypass allows unauthorized system-event injectionGHSA-qj22-xqjr-v83v
Fix: openclaw/openclaw@e56b0cfGHSA-qj22-xqjr-v83v is a security vulnerability in openclaw. A fix is available for openclaw — see the affected versions and patch details below.
Real-World Exposure
How broadly this vulnerability is actually deployed: weekly install volume shows current usage, and reverse-dependency count shows how many other packages break if it stays unpatched.
openclawnpmDescription
A missing sender-authorization check in Telegram message_reaction handling allowed unauthorized users to trigger reaction-derived system events.
Affected Packages / Versions
- Package:
openclaw(npm) - Introduced:
2026.2.17 - Affected:
>= 2026.2.17and<= 2026.2.24 - Latest published at patch time:
2026.2.24 - Patched in release:
2026.2.25
Impact
When reaction notifications are enabled, unauthorized Telegram senders could inject reaction system events despite configured DM/group authorization controls (dmPolicy, allowFrom, groupPolicy, groupAllowFrom).
Fix Commit(s)
e56b0cf1a04f992ac6ebc775899f48ea31687640
Release Process Note
patched_versions is pre-set to the release (2026.2.25) so once npm release 2026.2.25 is published, this advisory can be published without further edits.
OpenClaw thanks @tdjackey for reporting.
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| 📦npm | openclaw | all versions | 2026.2.25npm install openclaw@2026.2.25 |
Detection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for openclaw, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update openclaw to 2026.2.25 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms GHSA-qj22-xqjr-v83v is resolved across your whole dependency graph.
Workarounds
If you can't upgrade right away: gate or disable the affected feature, validate untrusted input at the boundary, and avoid passing attacker-controlled data into the vulnerable path. O3's runtime protection blocks exploitation in production as an interim safeguard until the upgrade lands.
Frequently Asked Questions
Is GHSA-qj22-xqjr-v83v in your dependencies?
Find it across npm, including transitive dependencies.