eZ Platform Prevent accepting app.php in URL in Platform.shGHSA-qhjc-hg94-245v
Fix: ezsystems/ezplatform@34ce867GHSA-qhjc-hg94-245v is a security vulnerability in ezsystems/ezplatform. A fix is available for ezsystems/ezplatform — see the affected versions and patch details below.
Real-World Exposure
ezsystems/ezplatform🐘ezsystems/ezplatform🐘ezsystems/ezplatformReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects Packagist packages — download data is not available via public APIs for these ecosystems.
Description
The recommended rewrite rules in eZ Platform prevent users from including the front-controller script (normally "app.php") in URLs. This prevents certain vulnerabilities related to caching. However, this is not possible when using eZ Platform Cloud (i.e. running eZ Platform on the Platform.sh cloud service), nor can it be done within the .platform.app.yaml configuration file. Therefore we need to reject such requests in the application itself. This advisory adds the prevention within the front controller script itself.
If you use eZ Platform Cloud / Platform.sh we recommend that you install this security update as soon as possible. It is distributed via Composer as ezsystems/ezplatform 1.7.9.1, and 1.13.5.1, and 2.5.4. This is the commit: https://github.com/ezsystems/ezplatform/commit/34ce86722b36a172e587068fe64a84faa7320cc2
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| 🐘Packagist | ezsystems/ezplatform | ≥ 2.5.0&&< 2.5.4 | 2.5.4composer require ezsystems/ezplatform:^2.5.4 |
| 🐘Packagist | ezsystems/ezplatform | ≥ 1.13.0&&< 1.13.5.1 | 1.13.5.1composer require ezsystems/ezplatform:^1.13.5.1 |
| 🐘Packagist | ezsystems/ezplatform | ≥ 1.7.0&&< 1.7.9.1 | 1.7.9.1composer require ezsystems/ezplatform:^1.7.9.1 |
Detection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for ezsystems/ezplatform, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update ezsystems/ezplatform to 2.5.4 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms GHSA-qhjc-hg94-245v is resolved across your whole dependency graph.
Workarounds
If you can't upgrade right away: gate or disable the affected feature, validate untrusted input at the boundary, and avoid passing attacker-controlled data into the vulnerable path. O3's runtime protection blocks exploitation in production as an interim safeguard until the upgrade lands.
Frequently Asked Questions
Is GHSA-qhjc-hg94-245v in your dependencies?
Find it across Packagist, including transitive dependencies.