Moodle self enrollment available before completing second factor with MFA enabledGHSA-qhc7-xhc2-7p7w
MEDIUMFix: moodle/moodle@b096513GHSA-qhc7-xhc2-7p7w is a medium-severity (CVSS 4.3) Improper Authentication vulnerability in moodle/moodle. A fix is available for moodle/moodle — see the affected versions and patch details below.
Exploitation Status
No confirmed exploitation observed yet
- CISA’s own triage has not observed active exploitation or public proof-of-concept code for this CVE as of its last assessment.
Exploitation and automatability from CISA’s SSVC triage for GHSA-qhc7-xhc2-7p7w.
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
How urgent is this, really
Where this sits among everything scored
Real-World Exposure
moodle/moodle🐘moodle/moodle🐘moodle/moodleReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects Packagist packages — download data is not available via public APIs for these ecosystems.
Description
A security vulnerability was discovered in Moodle that allows students to enroll themselves in courses without completing all the necessary safety checks. Specifically, users can sign up for courses prematurely, even if they haven't finished two-step verification processes.
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| 🐘Packagist | moodle/moodle | ≥ 4.3.0-beta&&< 4.3.12 | 4.3.12composer require moodle/moodle:^4.3.12 |
| 🐘Packagist | moodle/moodle | ≥ 4.4.0-beta&&< 4.4.8 | 4.4.8composer require moodle/moodle:^4.4.8 |
| 🐘Packagist | moodle/moodle | ≥ 4.5.0-beta&&< 4.5.4 | 4.5.4composer require moodle/moodle:^4.5.4 |
Affected Products
moodlemoodleDetection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for moodle/moodle, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update moodle/moodle to 4.3.12 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms GHSA-qhc7-xhc2-7p7w is resolved across your whole dependency graph.
Workarounds
Put an independent control in front of the weakness: restrict the affected endpoint or interface to trusted networks, require an additional authentication factor or proxy-level check, and invalidate existing sessions and credentials in case the flaw has already been used.
Frequently Asked Questions
Is GHSA-qhc7-xhc2-7p7w in your dependencies?
Find it across Packagist, including transitive dependencies.