OpenClaw: Feishu extension resolveUploadInput bypasses file-system sandbox and allows arbitrary file reads via upload_imageGHSA-qf48-qfv4-jjm9
MEDIUMFix: openclaw/openclaw@764394cGHSA-qf48-qfv4-jjm9 is a medium-severity (CVSS 5.3) Path Traversal vulnerability in openclaw. A fix is available for openclaw — see the affected versions and patch details below.
Exploitation Status
No confirmed exploitation observed yet
- CISA’s own triage has not observed active exploitation or public proof-of-concept code for this CVE as of its last assessment.
Exploitation and automatability from CISA’s SSVC triage for GHSA-qf48-qfv4-jjm9.
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
How urgent is this, really
Where this sits among everything scored
Real-World Exposure
How broadly this vulnerability is actually deployed: weekly install volume shows current usage, and reverse-dependency count shows how many other packages break if it stays unpatched.
openclawnpmDescription
Summary
Feishu upload path resolution could read files outside the configured localRoots sandbox before handing them to the upload path.
Impact
A tool caller constrained to workspace or localRoots paths could exfiltrate arbitrary host files through Feishu upload actions.
Affected Component
extensions/feishu/src/docx.ts
Fixed Versions
- Affected:
>= 2026.2.6, <= 2026.3.24 - Patched:
>= 2026.3.28 - Latest stable
2026.3.28contains the fix.
Fix
Fixed by commit 764394c78b (fix: enforce localRoots sandbox on Feishu docx upload file reads).
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| 📦npm | openclaw | ≥ 2026.2.6&&< 2026.3.28 | 2026.3.28npm install openclaw@2026.3.28 |
Affected Products
openclawopenclawDetection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for openclaw, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update openclaw to 2026.3.28 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms GHSA-qf48-qfv4-jjm9 is resolved across your whole dependency graph.
Workarounds
Resolve every user-supplied path to its canonical form and reject anything that escapes the intended directory, and run the component under an account that has no read or write access outside the directory it legitimately serves.
Frequently Asked Questions
Is GHSA-qf48-qfv4-jjm9 in your dependencies?
Find it across npm, including transitive dependencies.