NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
📦
📦 npm
Not in CISA KEV
CRITICAL severity

docusaurus-plugin-content-gists vulnerability exposes GitHub Personal Access TokenGHSA-qf34-qpr4-5pph

CRITICALFix: webbertakken/docusaurus-plugin-content-gists@8d4230b

GHSA-qf34-qpr4-5pph is a critical-severity (CVSS 10) Information Exposure vulnerability in docusaurus-plugin-content-gists. A fix is available for docusaurus-plugin-content-gists — see the affected versions and patch details below.

Also known asCVE-2025-53624
Published
Updated
Affected
1 pkg
Patched
1 / 1
Exploits
None indexed
Exploitation data as of Oct 29, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

Exploitation Status

No confirmed exploitation observed yet

  • CISA assesses this as automatable — exploitation doesn’t require manual, per-target effort, which raises the odds of mass scanning and opportunistic attacks.
  • A successful exploit gives an attacker total control of the affected component, not partial access.
  • CISA’s own triage has not observed active exploitation or public proof-of-concept code for this CVE as of its last assessment.

Exploitation and automatability from CISA’s SSVC triage for GHSA-qf34-qpr4-5pph.

EPSS Exploitation Probability

via FIRST.org ↗
2.0%probability of exploitation in next 30 days
Lower Risk+0.04%
Lower risk than most CVEs81th percentile — riskier than 81% of all scored CVEsHighest risk
0.00%6.04%12.1%18.1%8.0%2.0%Apr 26Aug 26Oct 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

1 pkg affected

How broadly this vulnerability is actually deployed: weekly install volume shows current usage, and reverse-dependency count shows how many other packages break if it stays unpatched.

0other npm packages depend on this — each one inherits the vulnerability until it's patched upstream
docusaurus-plugin-content-gistsnpm
138downloads / week

Description

GitHub Personal Access Token Exposure in docusaurus-plugin-content-gists

Summary

docusaurus-plugin-content-gists versions prior to 4.0.0 are vulnerable to exposing GitHub Personal Access Tokens in production build artifacts when passed through plugin configuration options. The token, intended for build-time API access only, is inadvertently included in client-side JavaScript bundles, making it accessible to anyone who can view the website's source code.

Affected Versions

  • All versions < 4.0.0

Patched Versions

  • Version 4.0.0 and later

Impact

When using the affected versions with the recommended configuration pattern:

plugins: [
  [
    'docusaurus-plugin-content-gists',
    {
      personalAccessToken: process.env.GITHUB_PERSONAL_ACCESS_TOKEN,
    },
  ],
]

The GitHub Personal Access Token is included in the webpack bundle and exposed in production builds at:

  • /build/assets/js/main.[hash].js

This allows malicious actors to:

  • Extract the GitHub Personal Access Token from the website's JavaScript files
  • Use the stolen token to access the token owner's GitHub account with the granted permissions
  • Potentially access private gists, repositories, or perform other actions depending on the token's scope

Mitigation steps

  1. Immediately revoke access to the GitHub PAT that was used: https://github.com/settings/tokens

Migration steps

  1. Update to version 4.0.0+: npm install docusaurus-plugin-content-gists@^4.0.0
  2. Remove personalAccessToken from your plugin configuration
  3. Ensure GH_PERSONAL_ACCESS_TOKEN is set in your build environment

Affected Packages

1 total 1 fixed
EcosystemPackageVulnerable rangeFix
📦npmdocusaurus-plugin-content-gistsall versions4.0.0npm install docusaurus-plugin-content-gists@4.0.0

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for docusaurus-plugin-content-gists, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update docusaurus-plugin-content-gists to 4.0.0 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms GHSA-qf34-qpr4-5pph is resolved across your whole dependency graph.

  3. Workarounds

    Assume what was exposed is already known: rotate any credential, token or key that the affected component could return, restrict the endpoint to callers that genuinely need it, and strip sensitive fields from responses and error output at the boundary rather than relying on the client not to read them.

How to detect GHSA-qf34-qpr4-5pph

A community-maintained Nuclei template exists for this CVE. You can scan for it directly:

nuclei -id ghsa-qf34-qpr4-5pph -u https://target
Template
Docusaurus Gists Plugin < 4.0.0 - GitHub Personal Access Token Exposure
Severity
high
Impact
A GitHub personal access token exposure vulnerability can grant an attacker unauthorized access to your repositories and organization resources, potentially leading to data exfiltration, code injection, and supply chain attacks.
Remediation
Update docusaurus-plugin-content-gists to version 4.0.0+. Revoke access to the GitHub PAT that was used: https://github.com/settings/tokens.

Template by ProjectDiscovery nuclei-templates (darses), MIT licensed. View the full template. Scan only systems you are authorised to test.

Frequently Asked Questions

## GitHub Personal Access Token Exposure in docusaurus-plugin-content-gists ### Summary docusaurus-plugin-content-gists versions prior to 4.0.0 are vulnerable to exposing GitHub Personal Access Tokens in production build artifacts when passed through plugin configuration options. The token, intended for build-time API access only, is inadvertently included in client-side JavaScript bundles, making it accessible to anyone who can view the website's source code. ### Affected Versions - All versions < 4.0.0 ### Patched Versions - Version 4.0.0 and later ### Impact When using the affected
O3 Security · Impact-Aware SCA

Is GHSA-qf34-qpr4-5pph in your dependencies?

Find it across npm, including transitive dependencies.

docusaurus-plugin-content-gists vulnerability exposes…