hull.js Code Injection VulnerabilityGHSA-q849-wxrc-vqrp
Fix: AndriiHeonia/hull@9de6f95GHSA-q849-wxrc-vqrp is a remote code execution vulnerability in hull.js. A fix is available for hull.js — see the affected versions and patch details below.
Real-World Exposure
How broadly this vulnerability is actually deployed: weekly install volume shows current usage, a proxy for how much of the ecosystem is exposed.
hull.jsnpmDescription
Versions of the library from 0.2.2 to 1.0.9 are vulnerable to the arbitrary code execution due to unsafe usage of new Function(...) in the module that handles points format. Applications passing the 3rd parameter to the hull function without sanitising may be impacted. The vulnerability has been fixed in version 1.0.10, please update the library. Check project homepage on GitHub to see how to fetch the latest version: https://github.com/andriiheonia/hull?tab=readme-ov-file#npm-package
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| 📦npm | hull.js | ≥ 0.2.2&&< 1.0.10 | 1.0.10npm install hull.js@1.0.10 |
Detection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for hull.js, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update hull.js to 1.0.10 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms GHSA-q849-wxrc-vqrp is resolved across your whole dependency graph.
Workarounds
If you can't upgrade right away: gate or disable the affected feature, validate untrusted input at the boundary, and avoid passing attacker-controlled data into the vulnerable path. O3's runtime protection blocks exploitation in production as an interim safeguard until the upgrade lands.
Frequently Asked Questions
Is GHSA-q849-wxrc-vqrp in your dependencies?
Find it across npm, including transitive dependencies.