DOMPDF denial of service vulnerabilityGHSA-q83c-64c9-c42m
MEDIUMGHSA-q83c-64c9-c42m is a medium-severity (CVSS 6.5) vulnerability in dompdf/dompdf. A fix is available for dompdf/dompdf — see the affected versions and patch details below.
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
How urgent is this, really
Where this sits among everything scored
Real-World Exposure
dompdf/dompdfReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects Packagist packages — download data is not available via public APIs for these ecosystems.
Description
DOMPDF before 0.6.2 allows denial of service.
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| 🐘Packagist | dompdf/dompdf | ≥ 0.6&&< 0.6.2 | 0.6.2composer require dompdf/dompdf:^0.6.2 |
Affected Products
dompdfdompdf_projectDetection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for dompdf/dompdf, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update dompdf/dompdf to 0.6.2 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms GHSA-q83c-64c9-c42m is resolved across your whole dependency graph.
Workarounds
Cap what an attacker can consume: apply request size, rate and timeout limits in front of the affected component, and run it with memory and CPU limits so exhaustion degrades one worker rather than the whole service.
Frequently Asked Questions
Is GHSA-q83c-64c9-c42m in your dependencies?
Find it across Packagist, including transitive dependencies.