@modelcontextprotocol/server-filesystem allows for path validation bypass via prefix matching and symlink handlingGHSA-q66q-fx2p-7w4m
Fix: modelcontextprotocol/servers@d00c60dGHSA-q66q-fx2p-7w4m is a CWE-59 vulnerability in @modelcontextprotocol/server-filesystem. A fix is available for @modelcontextprotocol/server-filesystem — see the affected versions and patch details below.
Exploitation Status
No confirmed exploitation observed yet
- CISA’s own triage has not observed active exploitation or public proof-of-concept code for this CVE as of its last assessment.
Exploitation and automatability from CISA’s SSVC triage for GHSA-q66q-fx2p-7w4m.
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
Real-World Exposure
How broadly this vulnerability is actually deployed: weekly install volume shows current usage, and reverse-dependency count shows how many other packages break if it stays unpatched.
@modelcontextprotocol/server-filesystemnpmDescription
Model Context Protocol Servers is a collection of reference implementations for the model context protocol (MCP). Versions of Filesystem prior to 0.6.4 or 2025.7.01 could allow access to unintended files via symlinks within allowed directories. Users are advised to upgrade to 0.6.4 or 2025.7.01 resolve.
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| 📦npm | @modelcontextprotocol/server-filesystem | all versions | No fix |
| 📦npm | @modelcontextprotocol/server-filesystem | ≥ 2025.1.14&&< 2025.7.1 | 2025.7.1npm install @modelcontextprotocol/server-filesystem@2025.7.1 |
Detection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for @modelcontextprotocol/server-filesystem, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
A fix is available for GHSA-q66q-fx2p-7w4m; check the affected-versions list above or the advisory for the patched release of @modelcontextprotocol/server-filesystem, then make sure no transitive dependency still pins the vulnerable range.
Workarounds
If you can't upgrade right away: gate or disable the affected feature, validate untrusted input at the boundary, and avoid passing attacker-controlled data into the vulnerable path. O3's runtime protection blocks exploitation in production as an interim safeguard until the upgrade lands.
Frequently Asked Questions
Is GHSA-q66q-fx2p-7w4m in your dependencies?
Find it across npm, including transitive dependencies.