NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
🐹
🐹 Go
Not in CISA KEV
HIGH severity

Helm's plugin verification fails open when .prov is missing, allowing unsigned plugin installGHSA-q5jf-9vfq-h4h7

HIGHFix: helm/helm@05fa379

GHSA-q5jf-9vfq-h4h7 is a high-severity (CVSS 7.8) CWE-636 vulnerability in helm.sh/helm/v4. A fix is available for helm.sh/helm/v4 — see the affected versions and patch details below.

Also known asBIT-helm-2026-35205CVE-2026-35205GO-2026-5566
Published
Updated
Affected
1 pkg
Patched
1 / 1
Exploits
None indexed
Exploitation data as of Nov 6, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

Exploitation Status

No confirmed exploitation observed yet

  • A successful exploit gives an attacker total control of the affected component, not partial access.
  • CISA’s own triage has not observed active exploitation or public proof-of-concept code for this CVE as of its last assessment.

Exploitation and automatability from CISA’s SSVC triage for GHSA-q5jf-9vfq-h4h7.

EPSS Exploitation Probability

via FIRST.org ↗
0.2%probability of exploitation in next 30 days
Lower Risk+0.00%
Lower risk than most CVEs13th percentile — riskier than 13% of all scored CVEsHighest risk
0.00%0.26%0.52%0.78%0.0%0.2%May 26Sep 26Nov 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

1 pkg affected
🐹helm.sh/helm/v4

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects Go packages — download data is not available via public APIs for these ecosystems.

Description

Helm is a package manager for Charts for Kubernetes. In Helm versions >=4.0.0 and <=4.1.3, Helm will install plugins missing provenance (.prov file) when signature verification is required.

Impact

The bug allows plugin authors to omit provenance (signing) data from plugins, bypassing plugin signature verification upon plugin install/update.

Notably, plugin hooks will be executed as designed on the installed plugin, enabling a malicious plugin to execute arbitrary code.

Patches

This issue has been patched in Helm v4.1.4

Installing/updating a plugin with missing provenance will error if signature verification is required.

Workarounds

Users may manually validate that a plugin archive is not missing provenance data (.prov file) before installation.

Affected Packages

1 total 1 fixed
EcosystemPackageVulnerable rangeFix
🐹Gohelm.sh/helm/v4≥ 4.0.0&&< 4.1.44.1.4go get helm.sh/helm/v4@v4.1.4

Affected Products

1 product · 1 configurations
Application
helmhelm
≥ 4.0.0 && < 4.1.4
range

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for helm.sh/helm/v4, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update helm.sh/helm/v4 to 4.1.4 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms GHSA-q5jf-9vfq-h4h7 is resolved across your whole dependency graph.

  3. Workarounds

    If you can't upgrade right away: gate or disable the affected feature, validate untrusted input at the boundary, and avoid passing attacker-controlled data into the vulnerable path. O3's runtime protection blocks exploitation in production as an interim safeguard until the upgrade lands.

Fixing This On Your OS

If you run this on a Linux distribution, patch through your package manager against the distro's own security advisory below — it tracks the exact backported fix for your release, which can ship on a different timeline (and sometimes a different severity) than the upstream project.

Red HatImportant
Workaround published by Red Hat
Mitigation for this issue is either not available or the currently available options do not meet the Red Hat Product Security criteria comprising ease of use and deployment, applicability to widespread installation base or stability.
Source: Red Hat security advisory for GHSA-q5jf-9vfq-h4h7 (CC BY 4.0)
ProductFixed inAdvisory
Helm CLI 4.1helm-cli-4.1.4RHSA-2026:26441

Frequently Asked Questions

Helm is a package manager for Charts for Kubernetes. In Helm versions >=4.0.0 and <=4.1.3, Helm will install plugins missing provenance (`.prov` file) when signature verification is required. ### Impact The bug allows plugin authors to omit provenance (signing) data from plugins, bypassing plugin signature verification upon plugin install/update. Notably, plugin hooks will be executed as designed on the installed plugin, enabling a malicious plugin to execute arbitrary code. ### Patches This issue has been patched in Helm v4.1.4 Installing/updating a plugin with missing provenance will e
O3 Security · Impact-Aware SCA

Is GHSA-q5jf-9vfq-h4h7 in your dependencies?

Find it across Go, including transitive dependencies.

Helm's plugin verification fails open when .prov is…