NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
🐍
🐍 PyPI
Not in CISA KEV
HIGH severity

httplib2 incorrectly checks SSL certificateGHSA-q48q-77qv-cf9p

HIGHFix: httplib2/httplib2@40cbdcc

GHSA-q48q-77qv-cf9p is a high-severity (CVSS 7.5) Improper Input Validation vulnerability in httplib2. 2 public exploit or proof-of-concept references are indexed, so weaponization risk is real. A fix is available for httplib2 — see the affected versions and patch details below.

Also known asCVE-2013-2037PYSEC-2014-81
Published
Updated
Affected
1 pkg
Patched
1 / 1
Exploits
2 known
Exploitation data as of Nov 5, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

EPSS Exploitation Probability

via FIRST.org ↗
1.3%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs71th percentile — riskier than 71% of all scored CVEsHighest risk
0.00%0.61%1.22%1.82%0.5%1.3%May 26Sep 26Nov 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

1 pkg affected
🐍httplib2

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects PyPI packages — download data is not available via public APIs for these ecosystems.

Description

httplib2 prior to version 0.10.1, after an initial connection is made, does not verify that the server hostname matches a domain name in the subject's Common Name (CN) or subjectAltName field of the X.509 certificate, which allows man-in-the-middle attackers to spoof SSL servers via an arbitrary valid certificate.

Affected Packages

1 total 1 fixed
EcosystemPackageVulnerable rangeFix
🐍PyPIhttplib2all versions0.10.1pip install --upgrade 'httplib2==0.10.1'

Affected Products

2 products · 6 configurations
OS
ubuntu linuxcanonical
4 versions
10.0412.0412.1013.04
Application
httplib2httplib2_project
≤ 0.7.2
1 version
0.8
Exploits & PoCs
2

Research use only. For defensive security, authorized penetration testing, and academic research only. Never execute exploit code against systems without explicit written authorization.

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for httplib2, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update httplib2 to 0.10.1 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms GHSA-q48q-77qv-cf9p is resolved across your whole dependency graph.

  3. Workarounds

    If you can't upgrade right away: gate or disable the affected feature, validate untrusted input at the boundary, and avoid passing attacker-controlled data into the vulnerable path. O3's runtime protection blocks exploitation in production as an interim safeguard until the upgrade lands.

Frequently Asked Questions

httplib2 prior to version 0.10.1, after an initial connection is made, does not verify that the server hostname matches a domain name in the subject's Common Name (CN) or subjectAltName field of the X.509 certificate, which allows man-in-the-middle attackers to spoof SSL servers via an arbitrary valid certificate.
O3 Security · Impact-Aware SCA

Is GHSA-q48q-77qv-cf9p in your dependencies?

Find it across PyPI, including transitive dependencies.

httplib2 incorrectly checks SSL certificate (High 7.5)