Django contains Uncontrolled Resource Consumption via cached headerGHSA-q2jf-h9jm-m7p4
HIGHFix: django/django@4452642GHSA-q2jf-h9jm-m7p4 is a high-severity (CVSS 7.5) CWE-770 vulnerability in django. EPSS puts its 30-day exploitation probability at 47.4% (99th percentile). A fix is available for django — see the affected versions and patch details below.
Exploitation Status
No confirmed exploitation observed yet
- CISA assesses this as automatable — exploitation doesn’t require manual, per-target effort, which raises the odds of mass scanning and opportunistic attacks.
- CISA’s own triage has not observed active exploitation or public proof-of-concept code for this CVE as of its last assessment.
Exploitation and automatability from CISA’s SSVC triage for GHSA-q2jf-h9jm-m7p4.
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
How urgent is this, really
Where this sits among everything scored
Real-World Exposure
django🐍django🐍djangoReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects PyPI packages — download data is not available via public APIs for these ecosystems.
Description
In Django 3.2 before 3.2.17, 4.0 before 4.0.9, and 4.1 before 4.1.6, the parsed values of Accept-Language headers are cached in order to avoid repetitive parsing. This leads to a potential denial-of-service vector via excessive memory usage if the raw value of Accept-Language headers is very large.
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| 🐍PyPI | django | ≥ 3.2a1&&< 3.2.17 | 3.2.17pip install --upgrade 'django==3.2.17' |
| 🐍PyPI | django | ≥ 4.0a1&&< 4.0.9 | 4.0.9pip install --upgrade 'django==4.0.9' |
| 🐍PyPI | django | ≥ 4.1a1&&< 4.1.6 | 4.1.6pip install --upgrade 'django==4.1.6' |
Affected Products
debian linuxdebiandjangodjangoprojectDetection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for django, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update django to 3.2.17 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms GHSA-q2jf-h9jm-m7p4 is resolved across your whole dependency graph.
Workarounds
Cap what an attacker can consume: apply request size, rate and timeout limits in front of the affected component, and run it with memory and CPU limits so exhaustion degrades one worker rather than the whole service.
Fixing This On Your OS
If you run this on a Linux distribution, patch through your package manager against the distro's own security advisory below — it tracks the exact backported fix for your release, which can ship on a different timeline (and sometimes a different severity) than the upstream project.
| Product | Fixed in | Advisory |
|---|---|---|
| Red Hat Satellite 6.13 for RHEL 8 | python-django-0:3.2.18-1.el8pc | RHSA-2023:2097 |
| RHUI 4 for RHEL 8 | python-django-0:3.2.18-1.0.1.el8ui | RHSA-2023:2101 |
Frequently Asked Questions
Is GHSA-q2jf-h9jm-m7p4 in your dependencies?
Find it across PyPI, including transitive dependencies.