NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
🐘
🐘 Packagist
Not in CISA KEV
CRITICAL severity

laravel-s vulnerable to Local File InclusionGHSA-q2fp-jw87-86px

CRITICALFix: hhxsv5/laravel-s@05aa615

GHSA-q2fp-jw87-86px is a critical-severity (CVSS 9.8) CWE-552 vulnerability in hhxsv5/laravel-s. 1 public exploit or proof-of-concept reference is indexed, so weaponization risk is real. A fix is available for hhxsv5/laravel-s — see the affected versions and patch details below.

Also known asCVE-2023-29931
Published
Updated
Affected
1 pkg
Patched
1 / 1
Exploits
1 known
Exploitation data as of Oct 31, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

Exploitation Status

Proof-of-concept exploit code exists

  • CISA’s SSVC triage found public proof-of-concept exploit code for this CVE, though no confirmed active exploitation.
  • CISA assesses this as automatable — exploitation doesn’t require manual, per-target effort, which raises the odds of mass scanning and opportunistic attacks.
  • A successful exploit gives an attacker total control of the affected component, not partial access.

Exploitation and automatability from CISA’s SSVC triage for GHSA-q2fp-jw87-86px.

EPSS Exploitation Probability

via FIRST.org ↗
0.9%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs60th percentile — riskier than 60% of all scored CVEsHighest risk
0.00%0.47%0.93%1.39%0.3%0.9%Apr 26Aug 26Oct 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

1 pkg affected
🐘hhxsv5/laravel-s

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects Packagist packages — download data is not available via public APIs for these ecosystems.

Description

laravel-s prior to 3.7.36 is vulnerable to Local File Inclusion via /src/Illuminate/Laravel.php.

Affected Packages

1 total 1 fixed
EcosystemPackageVulnerable rangeFix
🐘Packagisthhxsv5/laravel-sall versions3.7.36composer require hhxsv5/laravel-s:^3.7.36

Affected Products

1 product · 1 configurations
Application
laravelslaravels_project
1 version
3.7.35
Exploits & PoCs
1

Research use only. For defensive security, authorized penetration testing, and academic research only. Never execute exploit code against systems without explicit written authorization.

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for hhxsv5/laravel-s, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update hhxsv5/laravel-s to 3.7.36 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms GHSA-q2fp-jw87-86px is resolved across your whole dependency graph.

  3. Workarounds

    If you can't upgrade right away: gate or disable the affected feature, validate untrusted input at the boundary, and avoid passing attacker-controlled data into the vulnerable path. O3's runtime protection blocks exploitation in production as an interim safeguard until the upgrade lands.

Frequently Asked Questions

laravel-s prior to 3.7.36 is vulnerable to Local File Inclusion via `/src/Illuminate/Laravel.php`.
O3 Security · Impact-Aware SCA

Is GHSA-q2fp-jw87-86px in your dependencies?

Find it across Packagist, including transitive dependencies.

laravel-s vulnerable to Local File Inclusion (Critical 9.8)