NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
🐹
🐹 Go
Not in CISA KEV
MEDIUM severity

ydb-go-sdk token in custom credentials object can leak through logsGHSA-q24m-6h38-5xj8

MEDIUMFix: ydb-platform/ydb-go-sdk#859

GHSA-q24m-6h38-5xj8 is a medium-severity (CVSS 5.5) CWE-532 vulnerability in github.com/ydb-platform/ydb-go-sdk/v3. A fix is available for github.com/ydb-platform/ydb-go-sdk/v3 — see the affected versions and patch details below.

Also known asCVE-2023-45825GO-2023-2137
Published
Updated
Affected
1 pkg
Patched
1 / 1
Exploits
None indexed
Exploitation data as of Nov 6, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

Exploitation Status

No confirmed exploitation observed yet

  • CISA’s own triage has not observed active exploitation or public proof-of-concept code for this CVE as of its last assessment.

Exploitation and automatability from CISA’s SSVC triage for GHSA-q24m-6h38-5xj8.

EPSS Exploitation Probability

via FIRST.org ↗
0.2%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs14th percentile — riskier than 14% of all scored CVEsHighest risk
0.00%0.24%0.49%0.73%0.1%0.2%May 26Sep 26Nov 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

1 pkg affected
🐹github.com/ydb-platform/ydb-go-sdk/v3

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects Go packages — download data is not available via public APIs for these ecosystems.

Description

Impact

Since ydb-go-sdk/v3.48.6 if you use a custom credentials object (implementation of interface Credentials) it may leak into logs. This happens because this object could be serialized into an error message using fmt.Errorf("something went wrong (credentials: %q)", credentials) during connection to the YDB server. Printf func use placeholder %q for string representation of argument with quotes. If an argument implements interface fmt.Stringer, it will used through String() func. In other cases used fallback - serialization with reflection.

If such logging occurred, a malicious user with access to logs could read sensitive information (i.e. credentials) information and use it to get access to the database.

Who is impacted: applications with custom credentials object with an explicit token field.

A leak could have occurred if all of these conditions were met simultaneously:

  1. The credentials object does not implement the fmt.Stringer interface (does not have a String() method) - potentially these are custom credentials. Official credentials have a String() method.
  2. There was an error connecting to YDB during driver creation via ydb.Open(...).
  3. Some logging system was configured (ydb-go-sdk does not log such errors by default).
  4. The connection error was logged into a system that a malicious user had access to.

Patches

ydb-go-sdk contains this problem in versions from v3.48.6 to v3.53.2. The fix for this problem has been released in version v3.53.3 (PR).

Workarounds

Implement the fmt.Stringer interface in your custom credentials type with explicit stringify of object state.

Affected Packages

1 total 1 fixed
EcosystemPackageVulnerable rangeFix
🐹Gogithub.com/ydb-platform/ydb-go-sdk/v3≥ 3.48.6&&< 3.53.33.53.3go get github.com/ydb-platform/ydb-go-sdk/v3@v3.53.3

Affected Products

1 product · 1 configurations
Application
ydb-go-sdkydb
≥ 3.48.6 && < 3.53.2
range

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for github.com/ydb-platform/ydb-go-sdk/v3, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update github.com/ydb-platform/ydb-go-sdk/v3 to 3.53.3 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms GHSA-q24m-6h38-5xj8 is resolved across your whole dependency graph.

  3. Workarounds

    If you can't upgrade right away: gate or disable the affected feature, validate untrusted input at the boundary, and avoid passing attacker-controlled data into the vulnerable path. O3's runtime protection blocks exploitation in production as an interim safeguard until the upgrade lands.

Frequently Asked Questions

### Impact Since [ydb-go-sdk/v3.48.6](https://github.com/ydb-platform/ydb-go-sdk/blob/v3.48.6/internal/balancer/balancer.go#L71) if you use a custom credentials object (implementation of interface [Credentials](https://github.com/ydb-platform/ydb-go-sdk/blob/master/credentials/credentials.go#L10)) it may leak into logs. This happens because this object could be serialized into an error message using `fmt.Errorf("something went wrong (credentials: %q)", credentials)` during connection to the YDB server. Printf func use placeholder `%q` for string representation of argument with quotes. If an ar
O3 Security · Impact-Aware SCA

Is GHSA-q24m-6h38-5xj8 in your dependencies?

Find it across Go, including transitive dependencies.

GHSA-q24m-6h38-5xj8: ydb-go-sdk — Fixed in 3.53.3