GeoNode vulnerable to SSRF Bypass to return internal host dataGHSA-pxg5-h34r-7q8p
HIGHFix: GeoNode/geonode@79ac6e7GHSA-pxg5-h34r-7q8p is a high-severity (CVSS 7.5) Server-Side Request Forgery (SSRF) vulnerability in geonode. 1 public exploit or proof-of-concept reference is indexed, so weaponization risk is real. A fix is available for geonode — see the affected versions and patch details below.
Exploitation Status
Proof-of-concept exploit code exists
- CISA’s SSVC triage found public proof-of-concept exploit code for this CVE, though no confirmed active exploitation.
- CISA assesses this as automatable — exploitation doesn’t require manual, per-target effort, which raises the odds of mass scanning and opportunistic attacks.
Exploitation and automatability from CISA’s SSVC triage for GHSA-pxg5-h34r-7q8p.
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
How urgent is this, really
Where this sits among everything scored
Real-World Exposure
geonodeReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects PyPI packages — download data is not available via public APIs for these ecosystems.
Description
A SSRF vulnerability exists, bypassing existing controls on the software. This can allow a user to request internal services for a full read SSRF, returning any data from the internal network.
the application is using a whitelist, but the whitelist can be bypassed with @ and encoded value of @ (%40) GET /proxy/?url=http://development.demo.geonode.org%40geoserver:8080/geoserver/web This will trick the application that the first host is a whitelisted address, but the browser will use @ or %40 as a credential to the host geoserver on port 8080, this will return the data to that host on the response.

Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| 🐍PyPI | geonode | ≥ 3.2.0&&< 4.1.3.post1 | 4.1.3.post1pip install --upgrade 'geonode==4.1.3.post1' |
Affected Products
geonodegeosolutionsgroupResearch use only. For defensive security, authorized penetration testing, and academic research only. Never execute exploit code against systems without explicit written authorization.
Detection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for geonode, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update geonode to 4.1.3.post1 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms GHSA-pxg5-h34r-7q8p is resolved across your whole dependency graph.
Workarounds
Restrict outbound requests from the affected component to an allowlist of hosts, block access to link-local and internal address ranges at the network layer, and require authentication on internal services so a forged request cannot reach them unauthenticated.
Frequently Asked Questions
Is GHSA-pxg5-h34r-7q8p in your dependencies?
Find it across PyPI, including transitive dependencies.