NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
🐘
🐘 Packagist
Not in CISA KEV
HIGH severity

TeamPass Cross-site Scripting vulnerabilityGHSA-pwrw-g29q-3mp8

HIGHFix: nilsteampassnet/teampass@cb8ea5c

GHSA-pwrw-g29q-3mp8 is a high-severity (CVSS 8.1) Cross-site Scripting (XSS) vulnerability in nilsteampassnet/teampass. 1 public exploit or proof-of-concept reference is indexed, so weaponization risk is real. A fix is available for nilsteampassnet/teampass — see the affected versions and patch details below.

Also known asCVE-2023-3531
Published
Updated
Affected
1 pkg
Patched
1 / 1
Exploits
1 known
Exploitation data as of Nov 8, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

Exploitation Status

Proof-of-concept exploit code exists

  • CISA’s SSVC triage found public proof-of-concept exploit code for this CVE, though no confirmed active exploitation.
  • A successful exploit gives an attacker total control of the affected component, not partial access.

Exploitation and automatability from CISA’s SSVC triage for GHSA-pwrw-g29q-3mp8.

EPSS Exploitation Probability

via FIRST.org ↗
0.5%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs45th percentile — riskier than 45% of all scored CVEsHighest risk
0.00%0.35%0.69%1.04%0.1%0.5%May 26Sep 26Nov 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

1 pkg affected
🐘nilsteampassnet/teampass

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects Packagist packages — download data is not available via public APIs for these ecosystems.

Description

Cross-site Scripting (XSS) - Stored in GitHub repository nilsteampassnet/teampass prior to 3.0.10.

Affected Packages

1 total 1 fixed
EcosystemPackageVulnerable rangeFix
🐘Packagistnilsteampassnet/teampassall versions3.0.10composer require nilsteampassnet/teampass:^3.0.10

Affected Products

1 product · 1 configurations
Application
teampassteampass
< 3.0.10
range
Exploits & PoCs
1

Research use only. For defensive security, authorized penetration testing, and academic research only. Never execute exploit code against systems without explicit written authorization.

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for nilsteampassnet/teampass, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update nilsteampassnet/teampass to 3.0.10 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms GHSA-pwrw-g29q-3mp8 is resolved across your whole dependency graph.

  3. Workarounds

    Escape or sanitise the affected output on the server side rather than relying on client-side filtering, and add a Content-Security-Policy that blocks inline script execution so injected markup cannot run even if it reaches the page.

Frequently Asked Questions

Cross-site Scripting (XSS) - Stored in GitHub repository nilsteampassnet/teampass prior to 3.0.10.
O3 Security · Impact-Aware SCA

Is GHSA-pwrw-g29q-3mp8 in your dependencies?

Find it across Packagist, including transitive dependencies.

TeamPass Cross-site Scripting vulnerability (High 8.1)