NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
📦
📦 GitHub Actions
Not in CISA KEV
CRITICAL severity

j178/prek-action vulnerable to arbitrary code injection in composite actionGHSA-pwf7-47c3-mfhx

CRITICALFix: j178/prek-action@6b7c6ef

GHSA-pwf7-47c3-mfhx is a critical-severity (CVSS 9.9) remote code execution vulnerability in j178/prek-action. A fix is available for j178/prek-action — see the affected versions and patch details below.

Published
Updated
Affected
1 pkg
Patched
1 / 1
Exploits
None indexed
Exploitation data as of Sep 29, 2025 · OSV.dev, FIRST.org (EPSS)

Real-World Exposure

1 pkg affected
📦j178/prek-action

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects GitHub Actions packages — download data is not available via public APIs for these ecosystems.

Description

Summary

There are three potential attacks of arbitrary code injection vulnerability in the composite action at action.yml.

Details

The GitHub Action variables inputs.prek-version, inputs.extra_args, and inputs.extra-args can be used to execute arbitrary code in the context of the action.

PoC

- uses: j178/[email protected]
  with:
    prek-version: $(printenv >> $GITHUB_STEP_SUMMARY && echo "0.2.2")
    extra_args: '&& echo "MY_SECRET with a character is: ${MY_SECRET:0:1}a${MY_SECRET:1}" >> $GITHUB_STEP_SUMMARY && echo ""'
  env:
    MY_SECRET: ${{ secrets.MY_SECRET }}

The previous example will print all the environment variables, and it will expose MY_SECRET environment variable value to the summary of the workflow. An attacker could potentially use this vector to compromise the security of the target repository, even passing unnotice because the action will run normally.

Impact

Critical, CWE-94

Affected Packages

1 total 1 fixed
EcosystemPackageVulnerable rangeFix
📦GitHub Actionsj178/prek-actionall versions1.0.6

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for j178/prek-action, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update j178/prek-action to 1.0.6 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms GHSA-pwf7-47c3-mfhx is resolved across your whole dependency graph.

  3. Workarounds

    Stop passing untrusted input into the interpreter or shell: call the affected binary with an argument array rather than a composed command string, reject anything outside a strict allowlist of expected values, and run the component under an account that cannot reach beyond the work it legitimately does.

Frequently Asked Questions

### Summary There are three potential attacks of arbitrary code injection vulnerability in the composite action at _action.yml_. ### Details The GitHub Action variables `inputs.prek-version`, `inputs.extra_args`, and `inputs.extra-args` can be used to execute arbitrary code in the context of the action. ### PoC ```yaml - uses: j178/[email protected] with: prek-version: $(printenv >> $GITHUB_STEP_SUMMARY && echo "0.2.2") extra_args: '&& echo "MY_SECRET with a character is: ${MY_SECRET:0:1}a${MY_SECRET:1}" >> $GITHUB_STEP_SUMMARY && echo ""' env: MY_SECRET: ${{ secrets.MY_SECR
O3 Security · Impact-Aware SCA

Is GHSA-pwf7-47c3-mfhx in your dependencies?

Find it across GitHub Actions, including transitive dependencies.

GHSA-pwf7-47c3-mfhx: prek-action RCE — Fixed in 1.0.6