tar-fs Vulnerable to Link Following and Path Traversal via Extracting a Crafted tar FileGHSA-pq67-2wwv-3xjx
HIGHFix: mafintosh/tar-fs@a1dd7e7GHSA-pq67-2wwv-3xjx is a high-severity (CVSS 7.5) Path Traversal vulnerability in tar-fs. 1 public exploit or proof-of-concept reference is indexed, so weaponization risk is real. A fix is available for tar-fs — see the affected versions and patch details below.
Exploitation Status
No confirmed exploitation observed yet
- CISA assesses this as automatable — exploitation doesn’t require manual, per-target effort, which raises the odds of mass scanning and opportunistic attacks.
- CISA’s own triage has not observed active exploitation or public proof-of-concept code for this CVE as of its last assessment.
Exploitation and automatability from CISA’s SSVC triage for GHSA-pq67-2wwv-3xjx.
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
How urgent is this, really
Where this sits among everything scored
Real-World Exposure
How broadly this vulnerability is actually deployed: weekly install volume shows current usage, and reverse-dependency count shows how many other packages break if it stays unpatched.
tar-fsnpmDescription
An Improper Link Resolution Before File Access ("Link Following") and Improper Limitation of a Pathname to a Restricted Directory ("Path Traversal"). This vulnerability occurs when extracting a maliciously crafted tar file, which can result in unauthorized file writes or overwrites outside the intended extraction directory. The issue is associated with index.js in the tar-fs package.
This issue affects tar-fs: from 0.0.0 before 1.16.4, from 2.0.0 before 2.1.2, from 3.0.0 before 3.0.7.
PoC
// Create a writable stream to extract the tar content
const extractStream = tarfs.extract('/', {
// We can ignore the file type checks to allow the extraction of the malicious file
ignore: (name) => false,
});
// Create a tar stream
const tarStream = tarfs.pack().on('error', (err) => {
throw err;
});
// Append the malicious entry to the tar stream
tarStream.entry({ name: '/flag.txt', mode: 0o644 }, Buffer.from('This is a flag!'));
// Finalize the tar stream
tarStream.finalize();
// Pipe the tar stream into the extract stream
tarStream.pipe(extractStream);
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| 📦npm | tar-fs | all versions | 1.16.4npm install tar-fs@1.16.4 |
| 📦npm | tar-fs | ≥ 2.0.0&&< 2.1.2 | 2.1.2npm install tar-fs@2.1.2 |
| 📦npm | tar-fs | ≥ 3.0.0&&< 3.0.7 | 3.0.7npm install tar-fs@3.0.7 |
Research use only. For defensive security, authorized penetration testing, and academic research only. Never execute exploit code against systems without explicit written authorization.
tar-fs 3.0.0 - Arbitrary File Write/Overwrite
by cybersploit · Apr 22, 2025
Detection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for tar-fs, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update tar-fs to 1.16.4 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms GHSA-pq67-2wwv-3xjx is resolved across your whole dependency graph.
Workarounds
Resolve every user-supplied path to its canonical form and reject anything that escapes the intended directory, and run the component under an account that has no read or write access outside the directory it legitimately serves.
Fixing This On Your OS
If you run this on a Linux distribution, patch through your package manager against the distro's own security advisory below — it tracks the exact backported fix for your release, which can ship on a different timeline (and sometimes a different severity) than the upstream project.
This vulnerability is rated as an important severity because it allows attackers to extract a malicious tar file that can write or overwrite files outside the intended directory. This occurs due to improper handling of link resolution and pathname limitations. The risk is high for systems that automatically extract…
| Product | Fixed in | Advisory |
|---|---|---|
| Red Hat OpenShift Dev Spaces 3 Containers | devspaces/pluginregistry-rhel9:3.20-6 | RHSA-2025:3932 |
| Red Hat OpenShift Dev Spaces 3 Containers | devspaces/code-rhel9:3.21-5 | RHSA-2025:8244 |
| Red Hat Ceph Storage 7.1 | rhceph/rhceph-7-rhel9:1781863705 | RHSA-2026:33154 |
| Red Hat Developer Hub 1.5 | rhdh/rhdh-hub-rhel9:1.5.2-1748495853 | RHSA-2025:8540 |
| Red Hat Developer Hub 1.6 | rhdh/rhdh-hub-rhel9:1.6.0-1745956724 | RHSA-2025:7626 |
Frequently Asked Questions
Is GHSA-pq67-2wwv-3xjx in your dependencies?
Find it across npm, including transitive dependencies.