Netplex Json-smart Uncontrolled Recursion vulnerabilityGHSA-pq2g-wx69-c263
HIGHGHSA-pq2g-wx69-c263 is a high-severity (CVSS 7.5) CWE-674 vulnerability in net.minidev:json-smart. A fix is available for net.minidev:json-smart — see the affected versions and patch details below.
Exploitation Status
Proof-of-concept exploit code exists
- CISA’s SSVC triage found public proof-of-concept exploit code for this CVE, though no confirmed active exploitation.
- CISA assesses this as automatable — exploitation doesn’t require manual, per-target effort, which raises the odds of mass scanning and opportunistic attacks.
Exploitation and automatability from CISA’s SSVC triage for GHSA-pq2g-wx69-c263.
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
How urgent is this, really
Where this sits among everything scored
Real-World Exposure
net.minidev:json-smartReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects Maven packages — download data is not available via public APIs for these ecosystems.
Description
A security issue was found in Netplex Json-smart 2.5.0 through 2.5.1. When loading a specially crafted JSON input, containing a large number of ’{’, a stack exhaustion can be trigger, which could allow an attacker to cause a Denial of Service (DoS). This issue exists because of an incomplete fix for CVE-2023-1370.
The fixed version only addresses the default modes provided by JSONParser, such as MODE_RFC4627. If you create the JSONParser manually or with custom options, make sure to set the LIMIT_JSON_DEPTH option.
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| ☕Maven | net.minidev:json-smart | ≥ 2.5.0&&< 2.5.2 | 2.5.2net.minidev:json-smart:2.5.2 |
Detection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for net.minidev:json-smart, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update net.minidev:json-smart to 2.5.2 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms GHSA-pq2g-wx69-c263 is resolved across your whole dependency graph.
Workarounds
Cap what an attacker can consume: apply request size, rate and timeout limits in front of the affected component, and run it with memory and CPU limits so exhaustion degrades one worker rather than the whole service.
Fixing This On Your OS
If you run this on a Linux distribution, patch through your package manager against the distro's own security advisory below — it tracks the exact backported fix for your release, which can ship on a different timeline (and sometimes a different severity) than the upstream project.
This issue exists because of an incomplete fix for CVE-2023-1370, therefore it only affects json-smart v2.5.0 through v2.5.1 (inclusive).
Red Hat Product Security does not have a recommended mitigation at this time.Source: Red Hat security advisory for GHSA-pq2g-wx69-c263 (CC BY 4.0)
| Product | Fixed in | Advisory |
|---|---|---|
| HawtIO HawtIO 4.2.0 | json-smart | RHSA-2025:8761 |
| OCP-Tools-4.12-RHEL-8 | jenkins-0:2.504.2.1750932984-3.el8 | RHSA-2025:10118 |
| OCP-Tools-4.13-RHEL-8 | jenkins-0:2.504.2.1750916374-3.el8 | RHSA-2025:10119 |
| OCP-Tools-4.14-RHEL-8 | jenkins-0:2.504.2.1750903189-3.el8 | RHSA-2025:10120 |
| OCP-Tools-4.15-RHEL-8 | jenkins-0:2.504.2.1750856366-3.el8 | RHSA-2025:10104 |
| OCP-Tools-4.16-RHEL-9 | jenkins-0:2.504.2.1750857144-3.el9 | RHSA-2025:10098 |
| OCP-Tools-4.17-RHEL-9 | jenkins-0:2.504.2.1750851690-3.el9 | RHSA-2025:10097 |
| OCP-Tools-4.18-RHEL-9 | jenkins-0:2.504.2.1750846524-3.el9 | RHSA-2025:10092 |
Frequently Asked Questions
Is GHSA-pq2g-wx69-c263 in your dependencies?
Find it across Maven, including transitive dependencies.