NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
☕
☕ Maven
Not in CISA KEV
CRITICAL severity

Password in config file in KIE serverGHSA-pjw3-c74j-m9fj

CRITICALFix: kiegroup/droolsjbpm-integration#1273

GHSA-pjw3-c74j-m9fj is a critical-severity (CVSS 9.8) CWE-260 vulnerability in org.kie.server:kie-server-common. A fix is available for org.kie.server:kie-server-common — see the affected versions and patch details below.

Also known asCVE-2016-7043
Published
Updated
Affected
1 pkg
Patched
1 / 1
Exploits
None indexed
Exploitation data as of Nov 3, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

EPSS Exploitation Probability

via FIRST.org ↗
1.5%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs75th percentile — riskier than 75% of all scored CVEsHighest risk
0.00%0.68%1.35%2.03%0.2%1.5%May 26Sep 26Nov 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

1 pkg affected
☕org.kie.server:kie-server-common

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects Maven packages — download data is not available via public APIs for these ecosystems.

Description

It has been reported that KIE server and Busitess Central before version 7.21.0.Final contain username and password as plaintext Java properties. Any app deployed on the same server would have access to these properties, thus granting access to ther services.

Affected Packages

1 total 1 fixed
EcosystemPackageVulnerable rangeFix
☕Mavenorg.kie.server:kie-server-commonall versions7.21.0.Finalorg.kie.server:kie-server-common:7.21.0.Final

Affected Products

1 product · 1 configurations
Application
kie-serverredhat
< 7.21.0
range

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for org.kie.server:kie-server-common, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update org.kie.server:kie-server-common to 7.21.0.Final or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms GHSA-pjw3-c74j-m9fj is resolved across your whole dependency graph.

  3. Workarounds

    If you can't upgrade right away: gate or disable the affected feature, validate untrusted input at the boundary, and avoid passing attacker-controlled data into the vulnerable path. O3's runtime protection blocks exploitation in production as an interim safeguard until the upgrade lands.

Frequently Asked Questions

It has been reported that KIE server and Busitess Central before version 7.21.0.Final contain username and password as plaintext Java properties. Any app deployed on the same server would have access to these properties, thus granting access to ther services.
O3 Security · Impact-Aware SCA

Is GHSA-pjw3-c74j-m9fj in your dependencies?

Find it across Maven, including transitive dependencies.

Password in config file in KIE server (Critical 9.8)