NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
🐹
🐹 Go
Not in CISA KEV
HIGH severity

Possible image tampering from missing image validation for PackagesGHSA-pj4x-2xr5-w87m

HIGH

GHSA-pj4x-2xr5-w87m is a high-severity (CVSS 8.3) Improper Input Validation vulnerability in github.com/crossplane/crossplane. 1 public exploit or proof-of-concept reference is indexed, so weaponization risk is real. A fix is available for github.com/crossplane/crossplane — see the affected versions and patch details below.

Also known asBIT-crossplane-2023-38495CVE-2023-38495GO-2023-1980
Published
Updated
Affected
2 pkgs
Patched
2 / 2
Exploits
1 known
Exploitation data as of Nov 6, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

Exploitation Status

No confirmed exploitation observed yet

  • A successful exploit gives an attacker total control of the affected component, not partial access.
  • CISA’s own triage has not observed active exploitation or public proof-of-concept code for this CVE as of its last assessment.

Exploitation and automatability from CISA’s SSVC triage for GHSA-pj4x-2xr5-w87m.

EPSS Exploitation Probability

via FIRST.org ↗
0.8%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs58th percentile — riskier than 58% of all scored CVEsHighest risk
0.00%0.45%0.89%1.34%0.3%0.8%May 26Sep 26Nov 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

2 pkgs affected
🐹github.com/crossplane/crossplane🐹github.com/crossplane/crossplane

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects Go packages — download data is not available via public APIs for these ecosystems.

Description

Impact

Crossplanes image backend does not validate the byte contents of Crossplane packages. As such, Crossplane does not detect if an attacker has tampered with a Package.

Patches

The problem has been fixed in 1.11.5, 1.12.3 and 1.13.0, all the supported versions of Crossplane at the time of writing.

Workarounds

Only using images from trusted sources and keeping Package editing/creating privileges to administrators only, which should be both considered already best practices.

References

See ADA-XP-23-11 in the Security Audit's report.

Credits

This was reported as ADA-XP-23-11 by @AdamKorcz and @DavidKorczynski from Ada Logic and facilitated by OSTIF as part of the Security Audit sponsored by CNCF.

Affected Packages

2 total 2 fixed
EcosystemPackageVulnerable rangeFix
🐹Gogithub.com/crossplane/crossplaneall versions1.11.5go get github.com/crossplane/crossplane@v1.11.5
🐹Gogithub.com/crossplane/crossplane≥ 1.12.0&&< 1.12.31.12.3go get github.com/crossplane/crossplane@v1.12.3

Affected Products

1 product · 2 configurations
Application
crossplanecncf
≥ 1.12.0 && < 1.12.3
range
Exploits & PoCs
1

Research use only. For defensive security, authorized penetration testing, and academic research only. Never execute exploit code against systems without explicit written authorization.

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for github.com/crossplane/crossplane, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update github.com/crossplane/crossplane to 1.11.5 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms GHSA-pj4x-2xr5-w87m is resolved across your whole dependency graph.

  3. Workarounds

    If you can't upgrade right away: gate or disable the affected feature, validate untrusted input at the boundary, and avoid passing attacker-controlled data into the vulnerable path. O3's runtime protection blocks exploitation in production as an interim safeguard until the upgrade lands.

Frequently Asked Questions

### Impact Crossplanes image backend does not validate the byte contents of Crossplane packages. As such, Crossplane does not detect if an attacker has tampered with a Package. ### Patches The problem has been fixed in 1.11.5, 1.12.3 and 1.13.0, all the supported versions of Crossplane at the time of writing. ### Workarounds Only using images from trusted sources and keeping Package editing/creating privileges to administrators only, which should be both considered already best practices. ### References See `ADA-XP-23-11` in the Security Audit's [report](https://github.com/crossplane/cr
O3 Security · Impact-Aware SCA

Is GHSA-pj4x-2xr5-w87m in your dependencies?

Find it across Go, including transitive dependencies.

Possible image tampering from missing image validation…