NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
🐘
🐘 Packagist
Not in CISA KEV
MEDIUM severity

Server-Side Request Forgery in dompdf/dompdfGHSA-pf6p-25r2-fx45

MEDIUMFix: dompdf/dompdf@bb1ef65

GHSA-pf6p-25r2-fx45 is a medium-severity (CVSS 5.3) Server-Side Request Forgery (SSRF) vulnerability in dompdf/dompdf. 1 public exploit or proof-of-concept reference is indexed, so weaponization risk is real. A fix is available for dompdf/dompdf — see the affected versions and patch details below.

Also known asCVE-2022-0085
Published
Updated
Affected
1 pkg
Patched
1 / 1
Exploits
1 known
Exploitation data as of Nov 5, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

EPSS Exploitation Probability

via FIRST.org ↗
1.0%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs63th percentile — riskier than 63% of all scored CVEsHighest risk
0.00%0.50%1.00%1.50%0.4%1.0%May 26Sep 26Nov 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

1 pkg affected
🐘dompdf/dompdf

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects Packagist packages — download data is not available via public APIs for these ecosystems.

Description

Server-Side Request Forgery (SSRF) in GitHub repository dompdf/dompdf prior to 2.0.0.

Affected Packages

1 total 1 fixed
EcosystemPackageVulnerable rangeFix
🐘Packagistdompdf/dompdfall versions2.0.0composer require dompdf/dompdf:^2.0.0

Affected Products

1 product · 1 configurations
Application
dompdfdompdf_project
< 2.0.0
range
Exploits & PoCs
1

Research use only. For defensive security, authorized penetration testing, and academic research only. Never execute exploit code against systems without explicit written authorization.

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for dompdf/dompdf, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update dompdf/dompdf to 2.0.0 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms GHSA-pf6p-25r2-fx45 is resolved across your whole dependency graph.

  3. Workarounds

    Restrict outbound requests from the affected component to an allowlist of hosts, block access to link-local and internal address ranges at the network layer, and require authentication on internal services so a forged request cannot reach them unauthenticated.

Frequently Asked Questions

Server-Side Request Forgery (SSRF) in GitHub repository dompdf/dompdf prior to 2.0.0.
O3 Security · Impact-Aware SCA

Is GHSA-pf6p-25r2-fx45 in your dependencies?

Find it across Packagist, including transitive dependencies.

Server-Side Request Forgery in dompdf/dompdf