moonshine Stored Cross-Site Scripting Vulnerability in Create ArticleGHSA-p632-58pp-c9xg
MEDIUMFix: moonshine-software/moonshine@f108f4eGHSA-p632-58pp-c9xg is a medium-severity (CVSS 4.5) Cross-site Scripting (XSS) vulnerability in moonshine/moonshine. A fix is available for moonshine/moonshine — see the affected versions and patch details below.
Exploitation Status
Proof-of-concept exploit code exists
- CISA’s SSVC triage found public proof-of-concept exploit code for this CVE, though no confirmed active exploitation.
Exploitation and automatability from CISA’s SSVC triage for GHSA-p632-58pp-c9xg.
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
How urgent is this, really
Where this sits among everything scored
Real-World Exposure
moonshine/moonshineReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects Packagist packages — download data is not available via public APIs for these ecosystems.
Description
A Stored Cross-Site Scripting (XSS) vulnerability exists in MoonShine version < 3.12.5, allowing to execute arbitrary JavaScript by using "javascript:" payload, instead of the expected HTTPS protocol, in the CutCode Link parameter when creating/updating a new Article.
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| 🐘Packagist | moonshine/moonshine | all versions | 3.12.4composer require moonshine/moonshine:^3.12.4 |
Affected Products
moonshinemoonshineDetection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for moonshine/moonshine, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update moonshine/moonshine to 3.12.4 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms GHSA-p632-58pp-c9xg is resolved across your whole dependency graph.
Workarounds
Escape or sanitise the affected output on the server side rather than relying on client-side filtering, and add a Content-Security-Policy that blocks inline script execution so injected markup cannot run even if it reaches the page.
Frequently Asked Questions
Is GHSA-p632-58pp-c9xg in your dependencies?
Find it across Packagist, including transitive dependencies.