silverstripe/taxonomy SQL Injection vulnerabilityGHSA-p2v5-xcqm-4fv6
HIGHFix: silverstripe/silverstripe-taxonomy@01a5d9eGHSA-p2v5-xcqm-4fv6 is a high-severity (CVSS 7.5) vulnerability in silverstripe/taxonomy. A fix is available for silverstripe/taxonomy — see the affected versions and patch details below.
Real-World Exposure
silverstripe/taxonomy🐘silverstripe/taxonomyReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects Packagist packages — download data is not available via public APIs for these ecosystems.
Description
There is a vulnerability in silverstripe/taxonomy module that allows SQL injection. This affected controller (TaxonomyDirectoryController) is disabled by default and must be enabled by a developer for the exploit to be possible.
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| 🐘Packagist | silverstripe/taxonomy | ≥ 1.3.0&&< 1.3.1 | 1.3.1composer require silverstripe/taxonomy:^1.3.1 |
| 🐘Packagist | silverstripe/taxonomy | ≥ 2.0.0&&< 2.0.1 | 2.0.1composer require silverstripe/taxonomy:^2.0.1 |
Detection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for silverstripe/taxonomy, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update silverstripe/taxonomy to 1.3.1 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms GHSA-p2v5-xcqm-4fv6 is resolved across your whole dependency graph.
Workarounds
Until you can upgrade, make sure every query built from user input uses parameterised statements or a prepared-statement API rather than string concatenation, and reduce the database account's privileges so an injected query cannot read or alter data beyond what the feature needs.
Frequently Asked Questions
Is GHSA-p2v5-xcqm-4fv6 in your dependencies?
Find it across Packagist, including transitive dependencies.