NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
🐘
🐘 Packagist
Not in CISA KEV
MEDIUM severity

Dolibarr Cross-site scripting (XSS) vulnerabilityGHSA-p2fm-8rhj-58fr

MEDIUMFix: Dolibarr/dolibarr@1dc466e

GHSA-p2fm-8rhj-58fr is a medium-severity (CVSS 6.1) Cross-site Scripting (XSS) vulnerability in dolibarr/dolibarr. EPSS puts its 30-day exploitation probability at 86.5% (100th percentile). A fix is available for dolibarr/dolibarr — see the affected versions and patch details below.

Also known asCVE-2018-10095
Published
Updated
Affected
1 pkg
Patched
1 / 1
Exploits
None indexed
Exploitation data as of Nov 7, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

EPSS Exploitation Probability

via FIRST.org ↗
86.5%probability of exploitation in next 30 days
Very High Risk0.00%
Lower risk than most CVEs100th percentile — riskier than 100% of all scored CVEsHighest risk
35.7%56.7%77.8%98.8%47.5%86.5%May 26Sep 26Nov 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

1 pkg affected
🐘dolibarr/dolibarr

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects Packagist packages — download data is not available via public APIs for these ecosystems.

Description

Cross-site scripting (XSS) vulnerability in Dolibarr before 7.0.2 allows remote attackers to inject arbitrary web script or HTML via the foruserlogin parameter to adherents/cartes/carte.php.

Affected Packages

1 total 1 fixed
EcosystemPackageVulnerable rangeFix
🐘Packagistdolibarr/dolibarrall versions7.0.2composer require dolibarr/dolibarr:^7.0.2

Affected Products

1 product · 1 configurations
Application
dolibarrdolibarr
< 7.0.2
range

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for dolibarr/dolibarr, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update dolibarr/dolibarr to 7.0.2 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms GHSA-p2fm-8rhj-58fr is resolved across your whole dependency graph.

  3. Workarounds

    Escape or sanitise the affected output on the server side rather than relying on client-side filtering, and add a Content-Security-Policy that blocks inline script execution so injected markup cannot run even if it reaches the page.

How to detect GHSA-p2fm-8rhj-58fr

A community-maintained Nuclei template exists for this CVE. You can scan for it directly:

nuclei -id ghsa-p2fm-8rhj-58fr -u https://target
Template
Dolibarr <7.0.2 - Cross-Site Scripting
Severity
medium
Impact
Successful exploitation of this vulnerability could allow an attacker to execute arbitrary script code in the context of the victim's browser, potentially leading to session hijacking, defacement, or theft of sensitive information.
Remediation
Upgrade to Dolibarr version 7.0.2 or later to mitigate this vulnerability.

Template by ProjectDiscovery nuclei-templates (pikpikcu), MIT licensed. View the full template. Scan only systems you are authorised to test.

Frequently Asked Questions

Cross-site scripting (XSS) vulnerability in Dolibarr before 7.0.2 allows remote attackers to inject arbitrary web script or HTML via the foruserlogin parameter to adherents/cartes/carte.php.
O3 Security · Impact-Aware SCA

Is GHSA-p2fm-8rhj-58fr in your dependencies?

Find it across Packagist, including transitive dependencies.

Dolibarr Cross-site scripting (XSS) vulnerability