NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
📦 npm
Not in CISA KEV

Sveltejs devalue's `devalue.parse` and `devalue.unflatten` emit objects with `__proto__` own propertiesGHSA-mwv9-gp5h-frr4

Fix: sveltejs/devalue@87c1f3c

GHSA-mwv9-gp5h-frr4 is a security vulnerability in devalue. A fix is available for devalue — see the affected versions and patch details below.

Published
Updated
Affected
1 pkg
Patched
1 / 1
Exploits
None indexed
Exploitation data as of Jun 26, 2026 · OSV.dev, FIRST.org (EPSS)

Real-World Exposure

1 pkg affected

How broadly this vulnerability is actually deployed: weekly install volume shows current usage, and reverse-dependency count shows how many other packages break if it stays unpatched.

396other npm packages depend on this — each one inherits the vulnerability until it's patched upstream
devaluenpm
24.9Mdownloads / week

Description

In some circumstances, devalue.parse and devalue.unflatten could emit objects with __proto__ own properties. This in and of itself is not a security vulnerability (and is possible with, for example, JSON.parse as well), but it can result in prototype injection if downstream code handles it incorrectly:

const result = devalue.parse(/* input creating an object with a __proto__ property */);
const target = {};
Object.assign(target, result); // target's prototype is now polluted

Affected Packages

1 total 1 fixed
EcosystemPackageVulnerable rangeFix
📦npmdevalue≥ 4.0.0&&< 5.6.45.6.4npm install devalue@5.6.4

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for devalue, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update devalue to 5.6.4 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms GHSA-mwv9-gp5h-frr4 is resolved across your whole dependency graph.

  3. Workarounds

    If you can't upgrade right away: gate or disable the affected feature, validate untrusted input at the boundary, and avoid passing attacker-controlled data into the vulnerable path. O3's runtime protection blocks exploitation in production as an interim safeguard until the upgrade lands.

Frequently Asked Questions

In some circumstances, `devalue.parse` and `devalue.unflatten` could emit objects with `__proto__` own properties. This in and of itself is not a security vulnerability (and is possible with, for example, `JSON.parse` as well), but it can result in prototype injection if _downstream_ code handles it incorrectly: ```ts const result = devalue.parse(/* input creating an object with a __proto__ property */); const target = {}; Object.assign(target, result); // target's prototype is now polluted ```
O3 Security · Impact-Aware SCA

Is GHSA-mwv9-gp5h-frr4 in your dependencies?

Find it across npm, including transitive dependencies.

Sveltejs devalue's `devalue.parse` and `devalue.unflatten`…