symfony/ux-autocomplete: XSS via unescaped AJAX response dataGHSA-mwqm-4fw3-cjvr
Fix: symfony/ux@842ae54GHSA-mwqm-4fw3-cjvr is a Cross-site Scripting (XSS) vulnerability in symfony/ux-autocomplete. A fix is available for symfony/ux-autocomplete — see the affected versions and patch details below.
Exploitation Status
No confirmed exploitation observed yet
- CISA’s own triage has not observed active exploitation or public proof-of-concept code for this CVE as of its last assessment.
Exploitation and automatability from CISA’s SSVC triage for GHSA-mwqm-4fw3-cjvr.
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
Real-World Exposure
symfony/ux-autocomplete🐘symfony/ux-autocompleteReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects Packagist packages — download data is not available via public APIs for these ecosystems.
Description
Description
The Stimulus controller shipped with symfony/ux-autocomplete renders AJAX response items into the dropdown by interpolating the text field directly into HTML template literals (<div>${item[labelField]}</div>) inside _createAutocompleteWithRemoteData(). The value is parsed as HTML rather than text, so any markup contained in the AJAX response is executed by the browser.
When the dropdown values are derived from user-supplied content, an attacker can craft a string that triggers stored XSS in the browser of any other user who later opens a page containing an autocomplete widget backed by the same data.
Resolution
The option and item renderers used in _createAutocompleteWithRemoteData() now use TomSelect's escape helper to HTML-escape the value by default. Endpoints that legitimately return HTML (for example, to highlight the search term) can opt back in to the previous behavior by setting options_as_html: true. The AutocompleteChoiceTypeExtension normalizer that previously forced options_as_html=false when autocomplete_url was set has been dropped so the opt-in is reachable from the form layer.
The patch for this issue is available here for branch 2.x (and forward-ported to 3.x).
Credits
Symfony would like to thank Alex Ashkov for reporting the issue and Hugo Alliaume for providing the fix.
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| 🐘Packagist | symfony/ux-autocomplete | ≥ 2.2.0&&< 2.36.0 | 2.36.0composer require symfony/ux-autocomplete:^2.36.0 |
| 🐘Packagist | symfony/ux-autocomplete | ≥ 3.0.0&&< 3.1.0 | 3.1.0composer require symfony/ux-autocomplete:^3.1.0 |
Affected Products
uxsymfonyDetection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for symfony/ux-autocomplete, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update symfony/ux-autocomplete to 2.36.0 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms GHSA-mwqm-4fw3-cjvr is resolved across your whole dependency graph.
Workarounds
Escape or sanitise the affected output on the server side rather than relying on client-side filtering, and add a Content-Security-Policy that blocks inline script execution so injected markup cannot run even if it reaches the page.
Frequently Asked Questions
Is GHSA-mwqm-4fw3-cjvr in your dependencies?
Find it across Packagist, including transitive dependencies.