NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
☕
☕ Maven
Not in CISA KEV
HIGH severity

Insufficiently Protected Credentials in Jenkins AWS CodeBuild PluginGHSA-mwg7-69hf-vqh3

HIGHFix: jenkinsci/aws-codebuild-plugin@f5bae39

GHSA-mwg7-69hf-vqh3 is a high-severity (CVSS 7.8) CWE-522 vulnerability in com.amazonaws:aws-codebuild. A fix is available for com.amazonaws:aws-codebuild — see the affected versions and patch details below.

Also known asCVE-2018-1000404
Published
Updated
Affected
1 pkg
Patched
1 / 1
Exploits
None indexed
Exploitation data as of Nov 7, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

EPSS Exploitation Probability

via FIRST.org ↗
0.3%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs27th percentile — riskier than 27% of all scored CVEsHighest risk
0.00%0.28%0.56%0.84%0.0%0.3%May 26Sep 26Nov 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

1 pkg affected
☕com.amazonaws:aws-codebuild

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects Maven packages — download data is not available via public APIs for these ecosystems.

Description

Jenkins project Jenkins AWS CodeBuild Plugin version 0.26 and earlier contains a Insufficiently Protected Credentials vulnerability in AWSClientFactory.java, CodeBuilder.java that can result in Credentials Disclosure. This attack appear to be exploitable via local file access. This vulnerability appears to have been fixed in 0.27 and later.

Affected Packages

1 total 1 fixed
EcosystemPackageVulnerable rangeFix
☕Mavencom.amazonaws:aws-codebuildall versions0.27com.amazonaws:aws-codebuild:0.27

Affected Products

1 product · 1 configurations
Application
aws codebuildjenkins
≤ 0.26
range

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for com.amazonaws:aws-codebuild, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update com.amazonaws:aws-codebuild to 0.27 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms GHSA-mwg7-69hf-vqh3 is resolved across your whole dependency graph.

  3. Workarounds

    If you can't upgrade right away: gate or disable the affected feature, validate untrusted input at the boundary, and avoid passing attacker-controlled data into the vulnerable path. O3's runtime protection blocks exploitation in production as an interim safeguard until the upgrade lands.

Frequently Asked Questions

Jenkins project Jenkins AWS CodeBuild Plugin version 0.26 and earlier contains a Insufficiently Protected Credentials vulnerability in AWSClientFactory.java, CodeBuilder.java that can result in Credentials Disclosure. This attack appear to be exploitable via local file access. This vulnerability appears to have been fixed in 0.27 and later.
O3 Security · Impact-Aware SCA

Is GHSA-mwg7-69hf-vqh3 in your dependencies?

Find it across Maven, including transitive dependencies.

Insufficiently Protected Credentials in Jenkins AWS…