NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
📦
📦 npm
Not in CISA KEV
CRITICAL severity

Etherpad Lite Access Restriction BypassGHSA-mvmv-rq2j-97p2

CRITICALFix: ether/etherpad-lite@626e58c

GHSA-mvmv-rq2j-97p2 is a critical-severity (CVSS 9.8) Improper Input Validation vulnerability in ep_etherpad-lite. A fix is available for ep_etherpad-lite — see the affected versions and patch details below.

Also known asCVE-2018-6835
Published
Updated
Affected
1 pkg
Patched
1 / 1
Exploits
None indexed
Exploitation data as of Nov 7, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

EPSS Exploitation Probability

via FIRST.org ↗
2.3%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs83th percentile — riskier than 83% of all scored CVEsHighest risk
0.00%1.00%2.00%2.99%0.1%2.3%May 26Sep 26Nov 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

1 pkg affected

How broadly this vulnerability is actually deployed: weekly install volume shows current usage, and reverse-dependency count shows how many other packages break if it stays unpatched.

2other npm packages depend on this — each one inherits the vulnerability until it's patched upstream
ep_etherpad-litenpm
278downloads / week

Description

node/hooks/express/apicalls.js in Etherpad Lite before v1.6.3 mishandles JSONP, which allows remote attackers to bypass intended access restrictions.

Affected Packages

1 total 1 fixed
EcosystemPackageVulnerable rangeFix
📦npmep_etherpad-liteall versions1.6.3npm install ep_etherpad-lite@1.6.3

Affected Products

1 product · 1 configurations
Application
etherpadetherpad
< 1.6.3
range

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for ep_etherpad-lite, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update ep_etherpad-lite to 1.6.3 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms GHSA-mvmv-rq2j-97p2 is resolved across your whole dependency graph.

  3. Workarounds

    If you can't upgrade right away: gate or disable the affected feature, validate untrusted input at the boundary, and avoid passing attacker-controlled data into the vulnerable path. O3's runtime protection blocks exploitation in production as an interim safeguard until the upgrade lands.

Frequently Asked Questions

`node/hooks/express/apicalls.js` in Etherpad Lite before v1.6.3 mishandles JSONP, which allows remote attackers to bypass intended access restrictions.
O3 Security · Impact-Aware SCA

Is GHSA-mvmv-rq2j-97p2 in your dependencies?

Find it across npm, including transitive dependencies.

Etherpad Lite Access Restriction Bypass (Critical 9.8)