NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
🐘 Packagist
Not in CISA KEV

ps_checkout allows unauthorized method invocation through unvalidated parameterGHSA-mqq7-wxx5-mp8h

GHSA-mqq7-wxx5-mp8h is a security vulnerability in prestashop/ps_checkout. A fix is available for prestashop/ps_checkout — see the affected versions and patch details below.

Published
Updated
Affected
1 pkg
Patched
1 / 1
Exploits
None indexed
Exploitation data as of Sep 10, 2026 · OSV.dev, FIRST.org (EPSS)

Real-World Exposure

1 pkg affected
🐘prestashop/ps_checkout

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects Packagist packages — download data is not available via public APIs for these ecosystems.

Description

Impact

Unvalidated parameter can lead to some unauthorized method invocation with very little possibilities.

Patches

The problem has been patched in versions

  • v5.3.0 for PrestaShop 1.7 (build number: 7.5.3.0)
  • v5.3.0 for PrestaShop 8 (build number: 8.5.3.0)
  • v5.3.0 for PrestaShop 9 (build number: 9.5.3.0)

Read the Versioning policy to learn more about the build numbers.

Credits

PrestaShop thanks PATICEO for reporting the issue.

Affected Packages

1 total 1 fixed
EcosystemPackageVulnerable rangeFix
🐘Packagistprestashop/ps_checkoutall versions5.3.0composer require prestashop/ps_checkout:^5.3.0

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for prestashop/ps_checkout, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update prestashop/ps_checkout to 5.3.0 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms GHSA-mqq7-wxx5-mp8h is resolved across your whole dependency graph.

  3. Workarounds

    If you can't upgrade right away: gate or disable the affected feature, validate untrusted input at the boundary, and avoid passing attacker-controlled data into the vulnerable path. O3's runtime protection blocks exploitation in production as an interim safeguard until the upgrade lands.

Frequently Asked Questions

### Impact Unvalidated parameter can lead to some unauthorized method invocation with very little possibilities. ### Patches The problem has been patched in versions - v5.3.0 for PrestaShop 1.7 (build number: 7.5.3.0) - v5.3.0 for PrestaShop 8 (build number: 8.5.3.0) - v5.3.0 for PrestaShop 9 (build number: 9.5.3.0) Read the [Versioning policy](https://github.com/PrestaShopCorp/ps_checkout/wiki/Versioning) to learn more about the build numbers. ### Credits PrestaShop thanks [PATICEO](https://www.paticeo.com/) for reporting the issue.
O3 Security · Impact-Aware SCA

Is GHSA-mqq7-wxx5-mp8h in your dependencies?

Find it across Packagist, including transitive dependencies.

GHSA-mqq7-wxx5-mp8h: ps_checkout — Fixed in 5.3.0