AIOHTTP: WebSocket client accepts compressed frames without negotiated permessage-deflateGHSA-mq44-7p77-q5h7
Fix: aio-libs/aiohttp#12978GHSA-mq44-7p77-q5h7 is a Improper Input Validation vulnerability in aiohttp. A fix is available for aiohttp — see the affected versions and patch details below.
Exploitation Status
No confirmed exploitation observed yet
- CISA’s own triage has not observed active exploitation or public proof-of-concept code for this CVE as of its last assessment.
Exploitation and automatability from CISA’s SSVC triage for GHSA-mq44-7p77-q5h7.
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
Real-World Exposure
aiohttpReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects PyPI packages — download data is not available via public APIs for these ecosystems.
Description
Summary
The client accepts and decompresses frames with the RSV1 bit set even when the permessage-deflate extension was not negotiated.
Impact
A client may unexpectedly decompress WebSocket frames when explicitly opted out. This could lead to additional CPU/memory consumption, but is unlikely to be a significant issue unless a zip bomb vulnerability or similar is also present.
Patch: https://github.com/aio-libs/aiohttp/commit/47fb6ae354d4fa22048f4dbe7dbf82b625f0a2f6
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| 🐍PyPI | aiohttp | all versions | 3.14.2pip install --upgrade 'aiohttp==3.14.2' |
Detection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for aiohttp, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update aiohttp to 3.14.2 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms GHSA-mq44-7p77-q5h7 is resolved across your whole dependency graph.
Workarounds
If you can't upgrade right away: gate or disable the affected feature, validate untrusted input at the boundary, and avoid passing attacker-controlled data into the vulnerable path. O3's runtime protection blocks exploitation in production as an interim safeguard until the upgrade lands.
Fixing This On Your OS
If you run this on a Linux distribution, patch through your package manager against the distro's own security advisory below — it tracks the exact backported fix for your release, which can ship on a different timeline (and sometimes a different severity) than the upstream project.
Red Hat rates this flaw as Moderate with a CVSS score of 5.3 because exploitation requires an aiohttp WebSocket client to connect to an attacker-controlled server. In typical Red Hat product deployments, aiohttp serves as an HTTP client library for internal service communication rather than establishing WebSocket…
For deployments where upgrading is not immediately possible, ensure that aiohttp WebSocket clients only connect to trusted servers. The vulnerability requires the client to have opted out of permessage-deflate compression and the server to send RSV1-flagged frames, so connections using default compression settings are less likely to trigger this issue.Source: Red Hat security advisory for GHSA-mq44-7p77-q5h7 (CC BY 4.0)
| Product | Fixed in | Advisory |
|---|---|---|
| Red Hat AI Inference Server 3.2 | rhaiis/model-opt-cuda-rhel9:1790621714 | RHSA-2026:73859 |
| Red Hat AI Inference Server 3.2 | rhaiis/vllm-cuda-rhel9:1790621718 | RHSA-2026:73929 |
| Red Hat AI Inference Server 3.2 | rhaiis/vllm-rocm-rhel9:1790621713 | RHSA-2026:73930 |
| Red Hat AI Inference Server 3.4 | rhaii/vllm-cpu-rhel9:1790075793 | RHSA-2026:70965 |
| Red Hat AI Inference Server 3.4 | rhaii/vllm-spyre-rhel9:1790076141 | RHSA-2026:70969 |
| Red Hat AI Inference Server 3.4 | rhaii/vllm-cuda-rhel9:1790090131 | RHSA-2026:70979 |
| Red Hat AI Inference Server 3.4 | rhaii/vllm-rocm-rhel9:1790109620 | RHSA-2026:70995 |
Frequently Asked Questions
Is GHSA-mq44-7p77-q5h7 in your dependencies?
Find it across PyPI, including transitive dependencies.