@fastly/js-compute has a use-after-free in some host call implementationsGHSA-mp3g-vpm9-9vqv
MEDIUMFix: fastly/js-compute-runtime@4e16641GHSA-mp3g-vpm9-9vqv is a medium-severity (CVSS 5.3) Use After Free vulnerability in @fastly/js-compute. A fix is available for @fastly/js-compute — see the affected versions and patch details below.
Exploitation Status
No confirmed exploitation observed yet
- CISA’s own triage has not observed active exploitation or public proof-of-concept code for this CVE as of its last assessment.
Exploitation and automatability from CISA’s SSVC triage for GHSA-mp3g-vpm9-9vqv.
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
How urgent is this, really
Where this sits among everything scored
Real-World Exposure
How broadly this vulnerability is actually deployed: weekly install volume shows current usage, and reverse-dependency count shows how many other packages break if it stays unpatched.
@fastly/js-computenpmDescription
Impact
The implementation of the following functions were determined to include a use-after-free bug:
FetchEvent.client.tlsCipherOpensslNameFetchEvent.client.tlsProtocolFetchEvent.client.tlsClientCertificateFetchEvent.client.tlsJA3MD5FetchEvent.client.tlsClientHelloCacheEntry.prototype.userMetadataof thefastly:cachesubsystemDevice.lookupof thefastly:devicesubsystem
This bug could allow for an unintended data leak if the result of the preceding functions were sent anywhere else, and often results in a Compute service crash causing an HTTP 500 error to be returned. As all requests to Compute are isolated from one another, the only data at risk is data present for a single request.
Patches
This bug has been fixed in version 3.16.0 of the @fastly/js-compute package.
Workarounds
There are no workarounds for this bug, any use of the affected functions introduces the possibility of a data leak or crash in guest code.
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| 📦npm | @fastly/js-compute | ≥ 3.0.0&&< 3.16.0 | 3.16.0npm install @fastly/js-compute@3.16.0 |
Detection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for @fastly/js-compute, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update @fastly/js-compute to 3.16.0 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms GHSA-mp3g-vpm9-9vqv is resolved across your whole dependency graph.
Workarounds
Constrain what reaches the vulnerable code: limit the size and shape of untrusted input, isolate the affected component in a sandboxed or least-privileged process, and enable the platform's memory-safety mitigations (ASLR, stack protector, hardened allocator) so an out-of-bounds access is more likely to fail closed than to be exploitable.
Frequently Asked Questions
Is GHSA-mp3g-vpm9-9vqv in your dependencies?
Find it across npm, including transitive dependencies.