maxminddb's `Reader::open_mmap` unsoundly marks unsafe memmap operation as safeGHSA-mj73-j457-8x9q
Fix: oschwald/maxminddb-rust@98f0e4fGHSA-mj73-j457-8x9q is a security vulnerability in maxminddb. A fix is available for maxminddb — see the affected versions and patch details below.
Real-World Exposure
maxminddbReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects crates.io packages — download data is not available via public APIs for these ecosystems.
Description
maxminddb prior to version 0.27 declared Reader::open_mmap as safe despite wrapping an inherently unsafe memmap2 operation with no extra step done to guarantee safety. This could have led to undefined behaviour if the file were to be modified on disk while the memory map was still active.
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| 🦀crates.io | maxminddb | ≥ 0.11.0&&< 0.27.0 | 0.27.0cargo update -p maxminddb --precise 0.27.0 |
Detection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for maxminddb, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update maxminddb to 0.27.0 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms GHSA-mj73-j457-8x9q is resolved across your whole dependency graph.
Workarounds
If you can't upgrade right away: gate or disable the affected feature, validate untrusted input at the boundary, and avoid passing attacker-controlled data into the vulnerable path. O3's runtime protection blocks exploitation in production as an interim safeguard until the upgrade lands.
Frequently Asked Questions
Is GHSA-mj73-j457-8x9q in your dependencies?
Find it across crates.io, including transitive dependencies.