NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
🐘 Packagist
Not in CISA KEV

Magento Cross-Site Scripting (XSS) vulnerabilityGHSA-mcfc-67vm-j568

GHSA-mcfc-67vm-j568 is a security vulnerability in magento/community-edition. A fix is available for magento/community-edition — see the affected versions and patch details below.

Published
Updated
Affected
2 pkgs
Patched
2 / 2
Exploits
None indexed
Exploitation data as of Nov 29, 2024 · OSV.dev, FIRST.org (EPSS)

Real-World Exposure

2 pkgs affected
🐘magento/community-edition🐘magento/community-edition

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects Packagist packages — download data is not available via public APIs for these ecosystems.

Description

Magento Commerce and Open Source 2.2.6 and 2.1.15 contain multiple security enhancements that help close Cross-Site Scripting (XSS) and other vulnerabilities.

Affected Packages

2 total 2 fixed
EcosystemPackageVulnerable rangeFix
🐘Packagistmagento/community-edition≥ 2.1&&< 2.1.152.1.15composer require magento/community-edition:^2.1.15
🐘Packagistmagento/community-edition≥ 2.2&&< 2.2.62.2.6composer require magento/community-edition:^2.2.6

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for magento/community-edition, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update magento/community-edition to 2.1.15 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms GHSA-mcfc-67vm-j568 is resolved across your whole dependency graph.

  3. Workarounds

    Escape or sanitise the affected output on the server side rather than relying on client-side filtering, and add a Content-Security-Policy that blocks inline script execution so injected markup cannot run even if it reaches the page.

Frequently Asked Questions

Magento Commerce and Open Source 2.2.6 and 2.1.15 contain multiple security enhancements that help close Cross-Site Scripting (XSS) and other vulnerabilities.
O3 Security · Impact-Aware SCA

Is GHSA-mcfc-67vm-j568 in your dependencies?

Find it across Packagist, including transitive dependencies.

Magento Cross-Site Scripting (XSS) vulnerability