NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
📦
📦 npm
Not in CISA KEV
MEDIUM severity

@payloadcms/storage-vercel-blob has access control bypass of uploads in Vercel Storage adapterGHSA-mc8m-rr6c-r5qr

MEDIUMFix: payloadcms/payload@47abe9b

GHSA-mc8m-rr6c-r5qr is a medium-severity (CVSS 4.3) CWE-862 vulnerability in @payloadcms/storage-vercel-blob. A fix is available for @payloadcms/storage-vercel-blob — see the affected versions and patch details below.

Also known asCVE-2026-93363
Published
Updated
Affected
2 pkgs
Patched
2 / 2
Exploits
None indexed
Exploitation data as of Nov 6, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

Exploitation Status

No confirmed exploitation observed yet

  • CISA’s own triage has not observed active exploitation or public proof-of-concept code for this CVE as of its last assessment.

Exploitation and automatability from CISA’s SSVC triage for GHSA-mc8m-rr6c-r5qr.

EPSS Exploitation Probability

via FIRST.org ↗
0.2%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs7th percentile — riskier than 7% of all scored CVEsHighest risk
0.00%0.23%0.45%0.68%0.2%0.2%0.2%Oct 26Nov 26Nov 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

2 pkgs affected

How broadly this vulnerability is actually deployed: weekly install volume shows current usage, and reverse-dependency count shows how many other packages break if it stays unpatched.

8other npm packages depend on this — each one inherits the vulnerability until it's patched upstream
@payloadcms/storage-vercel-blobnpm
204Kdownloads / week

Description

Impact

In affected configurations, client upload access does not consistently align with the associated collection’s access configuration.

You are affected if:

  • You use client uploads with @payloadcms/storage-vercel-blob.
  • Authenticated users can access the client-upload route.

Applications that do not enable client uploads are not affected.

Patches

Client uploads now require authentication and the appropriate collection-level access before upload access is granted.

Users should upgrade Payload packages to >= 3.90.0 or >= 4.0.0-canary.34.

Workarounds

Upgrading to a patched version is recommended. Until you can upgrade, disable client uploads or configure the upload route’s access control to enforce the associated collection’s permissions.

Affected Packages

2 total 2 fixed
EcosystemPackageVulnerable rangeFix
📦npm@payloadcms/storage-vercel-blob≥ 3.25.0&&< 3.90.03.90.0npm install @payloadcms/storage-vercel-blob@3.90.0
📦npm@payloadcms/storage-vercel-blob≥ 4.0.0-canary.0&&< 4.0.0-canary.344.0.0-canary.34npm install @payloadcms/storage-vercel-blob@4.0.0-canary.34

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for @payloadcms/storage-vercel-blob, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update @payloadcms/storage-vercel-blob to 3.90.0 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms GHSA-mc8m-rr6c-r5qr is resolved across your whole dependency graph.

  3. Workarounds

    Put an independent control in front of the weakness: restrict the affected endpoint or interface to trusted networks, require an additional authentication factor or proxy-level check, and invalidate existing sessions and credentials in case the flaw has already been used.

Frequently Asked Questions

### Impact In affected configurations, client upload access does not consistently align with the associated collection’s access configuration. You are affected if: - You use client uploads with `@payloadcms/storage-vercel-blob`. - Authenticated users can access the client-upload route. Applications that do not enable client uploads are not affected. ### Patches Client uploads now require authentication and the appropriate collection-level access before upload access is granted. Users should upgrade Payload packages to `>= 3.90.0` or `>= 4.0.0-canary.34`. ### Workarounds Upgrading to a pat
O3 Security · Impact-Aware SCA

Is GHSA-mc8m-rr6c-r5qr in your dependencies?

Find it across npm, including transitive dependencies.

@payloadcms/storage-vercel-blob has access control…