NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
🐘
🐘 Packagist
Not in CISA KEV
MEDIUM severity

Cross-Site Scripting in CKEditor4 WordCount PluginGHSA-m8fw-p3cr-6jqc

MEDIUM

GHSA-m8fw-p3cr-6jqc is a medium-severity (CVSS 4.7) vulnerability in typo3/cms-rte-ckeditor. A fix is available for typo3/cms-rte-ckeditor — see the affected versions and patch details below.

Published
Updated
Affected
3 pkgs
Patched
3 / 3
Exploits
None indexed
Exploitation data as of Feb 4, 2026 · OSV.dev, FIRST.org (EPSS)

Real-World Exposure

3 pkgs affected
🐘typo3/cms-rte-ckeditor🐘typo3/cms-rte-ckeditor🐘typo3/cms-rte-ckeditor

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects Packagist packages — download data is not available via public APIs for these ecosystems.

Description

CVSS: CVSS:3.1/AV:N/AC:H/PR:N/UI:R/S:C/C:L/I:L/A:N/E:F/RL:O/RC:C (4.4)

Problem

The WordCount plugin (npm:ckeditor-wordcount-plugin) for CKEditor4 is vulnerable to cross-site scripting when switching to the source code mode. This plugin is enabled via the Full.yaml configuration present, but is not active in the default configuration.

In default scenarios, exploiting this vulnerability requires a valid backend user account. However, if custom plugins are used on the website frontend, which accept and reflect rich-text content submitted by users, no authentication is required.

Solution

Update to TYPO3 versions 9.5.42 ELTS, 10.4.39 ELTS, 11.5.30 that fix the problem described above.

Credits

Thanks to Sybille Peters who reported this issue, and to TYPO3 core & security team member Oliver Hader who fixed the issue.

References

Affected Packages

3 total 3 fixed
EcosystemPackageVulnerable rangeFix
🐘Packagisttypo3/cms-rte-ckeditor≥ 9.5.0&&< 9.5.429.5.42composer require typo3/cms-rte-ckeditor:^9.5.42
🐘Packagisttypo3/cms-rte-ckeditor≥ 10.0.0&&< 10.4.3910.4.39composer require typo3/cms-rte-ckeditor:^10.4.39
🐘Packagisttypo3/cms-rte-ckeditor≥ 11.0.0&&< 11.5.3011.5.30composer require typo3/cms-rte-ckeditor:^11.5.30

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for typo3/cms-rte-ckeditor, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update typo3/cms-rte-ckeditor to 9.5.42 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms GHSA-m8fw-p3cr-6jqc is resolved across your whole dependency graph.

  3. Workarounds

    Escape or sanitise the affected output on the server side rather than relying on client-side filtering, and add a Content-Security-Policy that blocks inline script execution so injected markup cannot run even if it reaches the page.

Frequently Asked Questions

> ### CVSS: `CVSS:3.1/AV:N/AC:H/PR:N/UI:R/S:C/C:L/I:L/A:N/E:F/RL:O/RC:C` (4.4) ### Problem The [WordCount](https://ckeditor.com/cke4/addon/wordcount) plugin ([`npm:ckeditor-wordcount-plugin`](https://www.npmjs.com/package/ckeditor-wordcount-plugin)) for CKEditor4 is vulnerable to cross-site scripting when switching to the source code mode. This plugin is enabled via the `Full.yaml` configuration present, but is not active in the default configuration. In default scenarios, exploiting this vulnerability requires a valid backend user account. However, if custom plugins are used on the website
O3 Security · Impact-Aware SCA

Is GHSA-m8fw-p3cr-6jqc in your dependencies?

Find it across Packagist, including transitive dependencies.

Cross-Site Scripting in CKEditor4 WordCount Plugin