Apache Linkis DataSource: DataSource module Oracle SQL Database Password LoggedGHSA-m757-p8rv-4q93
MEDIUMFix: apache/linkis@08cbcfcGHSA-m757-p8rv-4q93 is a medium-severity (CVSS 5.3) CWE-532 vulnerability in org.apache.linkis:linkis. A fix is available for org.apache.linkis:linkis — see the affected versions and patch details below.
Exploitation Status
No confirmed exploitation observed yet
- CISA’s own triage has not observed active exploitation or public proof-of-concept code for this CVE as of its last assessment.
Exploitation and automatability from CISA’s SSVC triage for GHSA-m757-p8rv-4q93.
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
How urgent is this, really
Where this sits among everything scored
Real-World Exposure
org.apache.linkis:linkisReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects Maven packages — download data is not available via public APIs for these ecosystems.
Description
In Apache Linkis <=1.4.0, The password is printed to the log when using the Oracle data source of the Linkis data source module. We recommend users upgrade the version of Linkis to version 1.5.0
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| ☕Maven | org.apache.linkis:linkis | all versions | 1.5.0org.apache.linkis:linkis:1.5.0 |
Affected Products
linkisapacheDetection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for org.apache.linkis:linkis, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update org.apache.linkis:linkis to 1.5.0 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms GHSA-m757-p8rv-4q93 is resolved across your whole dependency graph.
Workarounds
If you can't upgrade right away: gate or disable the affected feature, validate untrusted input at the boundary, and avoid passing attacker-controlled data into the vulnerable path. O3's runtime protection blocks exploitation in production as an interim safeguard until the upgrade lands.
Frequently Asked Questions
Is GHSA-m757-p8rv-4q93 in your dependencies?
Find it across Maven, including transitive dependencies.