Undici's Proxy-Authorization header not cleared on cross-origin redirect for dispatch, request, stream, pipelineGHSA-m4v8-wqvr-p9f7
LOWFix: nodejs/undici@64e3402GHSA-m4v8-wqvr-p9f7 is a low-severity (CVSS 3.9) CWE-285 vulnerability in undici. A fix is available for undici — see the affected versions and patch details below.
Exploitation Status
No confirmed exploitation observed yet
- CISA’s own triage has not observed active exploitation or public proof-of-concept code for this CVE as of its last assessment.
Exploitation and automatability from CISA’s SSVC triage for GHSA-m4v8-wqvr-p9f7.
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
How urgent is this, really
Where this sits among everything scored
Real-World Exposure
How broadly this vulnerability is actually deployed: weekly install volume shows current usage, and reverse-dependency count shows how many other packages break if it stays unpatched.
undicinpmDescription
Impact
Undici cleared Authorization and Proxy-Authorization headers for fetch(), but did not clear them for undici.request().
Patches
This has been patched in https://github.com/nodejs/undici/commit/6805746680d27a5369d7fb67bc05f95a28247d75. Fixes has been released in v5.28.4 and v6.11.1.
Workarounds
use fetch() or disable maxRedirections.
References
Linzi Shang reported this.
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| 📦npm | undici | all versions | 5.28.4npm install undici@5.28.4 |
| 📦npm | undici | ≥ 6.0.0&&< 6.11.1 | 6.11.1npm install undici@6.11.1 |
Affected Products
fedorafedoraprojectundicinodejsDetection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for undici, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update undici to 5.28.4 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms GHSA-m4v8-wqvr-p9f7 is resolved across your whole dependency graph.
Workarounds
Put an independent control in front of the weakness: restrict the affected endpoint or interface to trusted networks, require an additional authentication factor or proxy-level check, and invalidate existing sessions and credentials in case the flaw has already been used.
Fixing This On Your OS
If you run this on a Linux distribution, patch through your package manager against the distro's own security advisory below — it tracks the exact backported fix for your release, which can ship on a different timeline (and sometimes a different severity) than the upstream project.
Mitigation for this issue is either not available or the currently available options don't meet the Red Hat Product Security criteria comprising ease of use and deployment, applicability to widespread installation base or stability.Source: Red Hat security advisory for GHSA-m4v8-wqvr-p9f7 (CC BY 4.0)
| Product | Fixed in | Advisory |
|---|---|---|
| Red Hat OpenShift Dev Spaces 3 Containers | devspaces/dashboard-rhel8:3.16-27 | RHSA-2024:6667 |
Frequently Asked Questions
Is GHSA-m4v8-wqvr-p9f7 in your dependencies?
Find it across npm, including transitive dependencies.