NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
🐘
🐘 Packagist
Not in CISA KEV
MEDIUM severity

Moodle Improper Encoding or Escaping of OutputGHSA-m37g-mwcg-7j7v

MEDIUM

GHSA-m37g-mwcg-7j7v is a medium-severity (CVSS 4.9) CWE-116 vulnerability in moodle/moodle. A fix is available for moodle/moodle — see the affected versions and patch details below.

Also known asBIT-moodle-2021-40694CVE-2021-40694
Published
Updated
Affected
3 pkgs
Patched
3 / 3
Exploits
None indexed
Exploitation data as of Oct 30, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

EPSS Exploitation Probability

via FIRST.org ↗
0.9%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs60th percentile — riskier than 60% of all scored CVEsHighest risk
0.00%0.47%0.93%1.40%0.5%0.9%Apr 26Aug 26Oct 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

3 pkgs affected
🐘moodle/moodle🐘moodle/moodle🐘moodle/moodle

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects Packagist packages — download data is not available via public APIs for these ecosystems.

Description

Insufficient escaping of the LaTeX preamble made it possible for site administrators to read files available to the HTTP server system account.

Affected Packages

3 total 3 fixed
EcosystemPackageVulnerable rangeFix
🐘Packagistmoodle/moodle≥ 3.9&&< 3.9.103.9.10composer require moodle/moodle:^3.9.10
🐘Packagistmoodle/moodle≥ 3.10&&< 3.10.73.10.7composer require moodle/moodle:^3.10.7
🐘Packagistmoodle/moodle≥ 3.11&&< 3.11.33.11.3composer require moodle/moodle:^3.11.3

Affected Products

1 product · 3 configurations
Application
moodlemoodle
≥ 3.11.0 && < 3.11.3
range

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for moodle/moodle, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update moodle/moodle to 3.9.10 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms GHSA-m37g-mwcg-7j7v is resolved across your whole dependency graph.

  3. Workarounds

    If you can't upgrade right away: gate or disable the affected feature, validate untrusted input at the boundary, and avoid passing attacker-controlled data into the vulnerable path. O3's runtime protection blocks exploitation in production as an interim safeguard until the upgrade lands.

Frequently Asked Questions

Insufficient escaping of the LaTeX preamble made it possible for site administrators to read files available to the HTTP server system account.
O3 Security · Impact-Aware SCA

Is GHSA-m37g-mwcg-7j7v in your dependencies?

Find it across Packagist, including transitive dependencies.

Moodle Improper Encoding or Escaping of Output