OpenNMS Meridian and Horizon vulnerable to Cross-Site Request ForgeryGHSA-jxr6-7qg5-8wv6
MEDIUMFix: OpenNMS/opennms#5835GHSA-jxr6-7qg5-8wv6 is a medium-severity (CVSS 6.7) Cross-Site Request Forgery (CSRF) vulnerability in org.opennms:opennms-webapp. A fix is available for org.opennms:opennms-webapp — see the affected versions and patch details below.
Exploitation Status
No confirmed exploitation observed yet
- CISA’s own triage has not observed active exploitation or public proof-of-concept code for this CVE as of its last assessment.
Exploitation and automatability from CISA’s SSVC triage for GHSA-jxr6-7qg5-8wv6.
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
How urgent is this, really
Where this sits among everything scored
Real-World Exposure
org.opennms:opennms-webappReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects Maven packages — download data is not available via public APIs for these ecosystems.
Description
A form can be manipulated with cross-site request forgery in multiple versions of OpenNMS Meridian and Horizon. This can potentially allow an attacker to gain access to confidential information and compromise integrity. The solution is to upgrade to Meridian 2023.1.1 or Horizon 31.0.6 or newer. Meridian and Horizon installation instructions state that they are intended for installation within an organization's private networks and should not be directly accessible from the Internet.
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| ☕Maven | org.opennms:opennms-webapp | all versions | 31.0.6org.opennms:opennms-webapp:31.0.6 |
Affected Products
horizonopennmsmeridianopennmsDetection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for org.opennms:opennms-webapp, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update org.opennms:opennms-webapp to 31.0.6 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms GHSA-jxr6-7qg5-8wv6 is resolved across your whole dependency graph.
Workarounds
If you can't upgrade right away: gate or disable the affected feature, validate untrusted input at the boundary, and avoid passing attacker-controlled data into the vulnerable path. O3's runtime protection blocks exploitation in production as an interim safeguard until the upgrade lands.
Frequently Asked Questions
Is GHSA-jxr6-7qg5-8wv6 in your dependencies?
Find it across Maven, including transitive dependencies.