Statamic is vulnerable to account takeover via password reset link injectionGHSA-jxq9-79vj-rgvw
CRITICALFix: statamic/cms@6fdd033GHSA-jxq9-79vj-rgvw is a critical-severity (CVSS 9.3) CWE-640 vulnerability in statamic/cms. A fix is available for statamic/cms — see the affected versions and patch details below.
Exploitation Status
No confirmed exploitation observed yet
- CISA’s own triage has not observed active exploitation or public proof-of-concept code for this CVE as of its last assessment.
Exploitation and automatability from CISA’s SSVC triage for GHSA-jxq9-79vj-rgvw.
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
How urgent is this, really
Where this sits among everything scored
Real-World Exposure
statamic/cms🐘statamic/cmsReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects Packagist packages — download data is not available via public APIs for these ecosystems.
Description
Impact
An attacker may leverage a vulnerability in the password reset feature to capture a user's token and reset the password on their behalf.
The attacker must know the email address of a valid account on the site, and the actual user must blindly click the link in their email even though they didn't request the reset.
Patches
This has been fixed in 6.7.1 and 5.73.10.
Note that a follow-up report showed the original 6.3.3 fix to be insufficient. The 5.73.10 fix was sufficient.
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| 🐘Packagist | statamic/cms | all versions | 5.73.10composer require statamic/cms:^5.73.10 |
| 🐘Packagist | statamic/cms | ≥ 6.0.0-alpha.1&&< 6.7.1 | 6.7.1composer require statamic/cms:^6.7.1 |
Affected Products
statamicstatamicDetection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for statamic/cms, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update statamic/cms to 5.73.10 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms GHSA-jxq9-79vj-rgvw is resolved across your whole dependency graph.
Workarounds
If you can't upgrade right away: gate or disable the affected feature, validate untrusted input at the boundary, and avoid passing attacker-controlled data into the vulnerable path. O3's runtime protection blocks exploitation in production as an interim safeguard until the upgrade lands.
Frequently Asked Questions
Is GHSA-jxq9-79vj-rgvw in your dependencies?
Find it across Packagist, including transitive dependencies.