NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
🐍
🐍 PyPI
Not in CISA KEV
HIGH severity

scikit-learn Denial of ServiceGHSA-jxfp-4rvq-9h9m

HIGHFix: scikit-learn/scikit-learn@1bf13d5

GHSA-jxfp-4rvq-9h9m is a high-severity (CVSS 7.5) vulnerability in scikit-learn. 3 public exploit or proof-of-concept references are indexed, so weaponization risk is real. A fix is available for scikit-learn — see the affected versions and patch details below.

Also known asCVE-2020-28975PYSEC-2020-108
Published
Updated
Affected
1 pkg
Patched
1 / 1
Exploits
3 known
Exploitation data as of Nov 7, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

Exploitation Status

Proof-of-concept exploit code exists

  • CISA’s SSVC triage found public proof-of-concept exploit code for this CVE, though no confirmed active exploitation.

Exploitation and automatability from CISA’s SSVC triage for GHSA-jxfp-4rvq-9h9m.

EPSS Exploitation Probability

via FIRST.org ↗
3.6%probability of exploitation in next 30 days
Lower Risk+0.07%
Lower risk than most CVEs89th percentile — riskier than 89% of all scored CVEsHighest risk
0.00%1.52%3.04%4.56%0.3%3.6%May 26Sep 26Nov 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

1 pkg affected
🐍scikit-learn

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects PyPI packages — download data is not available via public APIs for these ecosystems.

Description

svm_predict_values in svm.cpp in Libsvm v324, as used in scikit-learn 0.23.2 and other products, allows attackers to cause a denial of service (segmentation fault) via a crafted model SVM (introduced via pickle, json, or any other model permanence standard) with a large value in the _n_support array. NOTE: the scikit-learn vendor's position is that the behavior can only occur if the library's API is violated by an application that changes a private attribute.

Affected Packages

1 total 1 fixed
EcosystemPackageVulnerable rangeFix
🐍PyPIscikit-learn≥ 0.23.2&&< 1.0.11.0.1pip install --upgrade 'scikit-learn==1.0.1'

Affected Products

1 product · 1 configurations
Application
scikit-learnscikit-learn
≥ 0.23.2 && < 1.0.1
range
Exploits & PoCs
3

Research use only. For defensive security, authorized penetration testing, and academic research only. Never execute exploit code against systems without explicit written authorization.

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for scikit-learn, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update scikit-learn to 1.0.1 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms GHSA-jxfp-4rvq-9h9m is resolved across your whole dependency graph.

  3. Workarounds

    Cap what an attacker can consume: apply request size, rate and timeout limits in front of the affected component, and run it with memory and CPU limits so exhaustion degrades one worker rather than the whole service.

Frequently Asked Questions

svm_predict_values in svm.cpp in Libsvm v324, as used in scikit-learn 0.23.2 and other products, allows attackers to cause a denial of service (segmentation fault) via a crafted model SVM (introduced via pickle, json, or any other model permanence standard) with a large value in the _n_support array. NOTE: the scikit-learn vendor's position is that the behavior can only occur if the library's API is violated by an application that changes a private attribute.
O3 Security · Impact-Aware SCA

Is GHSA-jxfp-4rvq-9h9m in your dependencies?

Find it across PyPI, including transitive dependencies.

scikit-learn Denial of Service (High 7.5)